summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-11-17 13:22:32 -0600
committerLuis Martinez2022-11-17 13:22:32 -0600
commitbe180011c5121c233b14c1154940fd09d3adae1b (patch)
treeedf9809adf9499dc824272cc0bc23f1156a20db8
parent6e26cc73a1ab24a81c90378acb5f7ff7a2caf932 (diff)
downloadaur-fnott.tar.gz
update to 1.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md139
-rw-r--r--PKGBUILD6
3 files changed, 119 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 871155e680d9..88655cfa8cb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fnott
pkgdesc = Keyboard driven and lightweight Wayland notification daemon
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://codeberg.org/dnkl/fnott
changelog = CHANGELOG.md
@@ -13,7 +13,7 @@ pkgbase = fnott
depends = dbus
depends = fcft
depends = wlroots
- source = fnott-1.2.1.tar.gz::https://codeberg.org/dnkl/fnott/archive/1.2.1.tar.gz
- sha256sums = a4e72845cde23aff0653f9b218a32cb40ae628b3f690dc02333ea95469faf216
+ source = fnott-1.3.0.tar.gz::https://codeberg.org/dnkl/fnott/archive/1.3.0.tar.gz
+ sha256sums = d17d6a55a7e0d56ddfc3277fbbefa7baf4c70f02265bcb8bd72ee464e202e454
pkgname = fnott
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 9f3b5e6a6410..18a8a1197a06 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,6 @@
# Changelog
+* [1.3.0](#1-3-0)
* [1.2.1](#1-2-1)
* [1.2.0](#1-2-0)
* [1.1.2](#1-1-2)
@@ -9,12 +10,81 @@
* [1.0.0](#1-0-0)
+## 1.3.0
+
+### Added
+
+* Support for a “progress” hints, `notify-send -h int:value:20 ...`,
+ ([#51][51]).
+* `title-format`, `summary-format` and `body-format` options, allowing
+ you to customize the rendered strings. In this release, the `%a`,
+ `%s`, `%b` and `%%` formatters, as well as `\n`, are
+ recognized. ([#39][39]).
+* Added configuration option `layer` to specify the layer on which notifications
+ are displayed. Values include `background`, `top`, `bottom`, and `overlay`
+ ([#71][71]).
+
+[51]: https://codeberg.org/dnkl/fnott/issues/51
+[39]: https://codeberg.org/dnkl/fnott/issues/39
+[71]: https://codeberg.org/dnkl/fnott/issues/71
+
+
+### Changed
+
+* Minimum required meson version is now 0.58.
+* Notification text is now truncated instead of running into, and
+ past, the vertical padding ([#52][52]).
+* All color configuration options have been changed from (A)RGB
+ (i.e. ARGB, where the alpha component is optional), to RGBA. This
+ means **all** color values **must** be specified with 8 digits
+ ([#47][47]).
+
+[52]: https://codeberg.org/dnkl/fnott/issues/52
+[47]: https://codeberg.org/dnkl/fnott/issues/47
+
+
+### Removed
+
+* `$XDG_CONFIG_HOME/fnottrc` and `~/.config/fnottrc`. Use
+ `$XDG_CONFIG_HOME/fnott/fnott.ini` (defaulting to
+ `~/.config/fnott/fnott.ini`) instead ([#7][7]).
+
+[7]: https://codeberg.org/dnkl/fnott/issues/7
+
+
+### Fixed
+
+* Scale not being applied to the notification’s size when first
+ instantiated ([#54][54]).
+* Fallback to `/etc/xdg` if `XDG_CONFIG_DIRS` is unset.
+* Icon lookup is now better at following the XDG specification
+ ([#64][64]).
+* Setting `max-width` and/or `max-height` to 0 no longer causes fnott
+ to crash. Instead, a zero max-width/height means there is no limit
+ ([#66][66]).
+
+[54]: https://codeberg.org/dnkl/fnott/issues/54
+[64]: https://codeberg.org/dnkl/fnott/issues/64
+[66]: https://codeberg.org/dnkl/fnott/issues/66
+
+
+### Contributors
+
+* bagnaram
+* Humm
+* Leonardo Hernández Hernández
+* Mark Stosberg
+* merkix
+
+
## 1.2.1
### Fixed
* Crash when receiving notification with inline image data
- (https://codeberg.org/dnkl/fnott/issues/44).
+ ([#44][44]).
+
+[44]: https://codeberg.org/dnkl/fnott/issues/44
## 1.2.0
@@ -22,8 +92,9 @@
### Added
* Configurable padding of notification text. New `fnottrc` options:
- `padding-vertical` and `padding-horizontal`
- (https://codeberg.org/dnkl/fnott/issues/35).
+ `padding-vertical` and `padding-horizontal` ([#35][35]).
+
+[35]: https://codeberg.org/dnkl/fnott/issues/35
### Changed
@@ -36,13 +107,15 @@
* `fnottctl actions` exiting without receiving a reply.
* Fnott is now much better at surviving monitors being disabled and
- re-enabled (https://codeberg.org/dnkl/fnott/issues/25).
+ re-enabled ([#25][25]).
* Wrong font being used when the body and summary (or title and body,
- or title and summary) is set to the same text
- (https://codeberg.org/dnkl/fnott/issues/36).
+ or title and summary) is set to the same text ([#36][36]).
* Fnott no longer allocates the vertical padding space between summary
- and body text, if the body text is empty
- (https://codeberg.org/dnkl/fnott/issues/41).
+ and body text, if the body text is empty ([#41][41]).
+
+[25]: https://codeberg.org/dnkl/fnott/issues/25
+[36]: https://codeberg.org/dnkl/fnott/issues/36
+[41]: https://codeberg.org/dnkl/fnott/issues/41
### Contributors
@@ -56,7 +129,9 @@
### Fixed
* `max-timeout` not having any effect when the timeout is 0
- (https://codeberg.org/dnkl/fnott/issues/32).
+ ([#32][32]).
+
+[32]: https://codeberg.org/dnkl/fnott/issues/32
## 1.1.1
@@ -64,9 +139,11 @@
### Added
* `default-timeout` option, to adjust the timeout when applications
- ask us to pick the timeout
- (https://codeberg.org/dnkl/fnott/issues/27).
-* `max-timeout` option (https://codeberg.org/dnkl/fnott/issues/29).
+ ask us to pick the timeout ([#27][27]).
+* `max-timeout` option ([#29][29]).
+
+[27]: https://codeberg.org/dnkl/fnott/issues/27
+[29]: https://codeberg.org/dnkl/fnott/issues/29
### Changed
@@ -77,18 +154,19 @@
### Removed
-* `timeout` option (replaced with `max-timeout`,
- https://codeberg.org/dnkl/fnott/issues/29).
+* `timeout` option (replaced with `max-timeout`, [#29][29]).
### Fixed
* Icons not being searched for in all icon theme instances
- (https://codeberg.org/dnkl/fnott/issues/17).
+ ([#17][17]).
* fnott crashing when a notification was received while no monitor was
attached to the wayland session.
* Wrong colors in (semi-)transparent areas of SVG icons.
+[17]: https://codeberg.org/dnkl/fnott/issues/17
+
### Contributors
@@ -106,15 +184,19 @@
* Configurable anchor point and margins. New `fnottrc` options:
`anchor=top-left|top-right|bottom-left|bottom-right`,
`edge-margin-vertical`, `edge-margin-horizontal` and
- `notification-margin` (https://codeberg.org/dnkl/fnott/issues/4).
-* `-c,--config=PATH` command line option
- (https://codeberg.org/dnkl/fnott/issues/10).
-* Text shaping support (https://codeberg.org/dnkl/fnott/issues/13).
+ `notification-margin` ([#4][4]).
+* `-c,--config=PATH` command line option ([#10][10]).
+* Text shaping support ([#13][13]).
* `play-sound` to `fnott.ini`, specifying the command to execute to
- play a sound (https://codeberg.org/dnkl/fnott/issues/12).
+ play a sound ([#12][12]).
* `sound-file`, a per-urgency option in `fnott.ini`, specifying the
path to an audio file to play when a notification is received
- (https://codeberg.org/dnkl/fnott/issues/12).
+ ([#12][12]).
+
+[4]: https://codeberg.org/dnkl/fnott/issues/4
+[10]: https://codeberg.org/dnkl/fnott/issues/10
+[13]: https://codeberg.org/dnkl/fnott/issues/13
+[12]: https://codeberg.org/dnkl/fnott/issues/12
### Changed
@@ -122,18 +204,21 @@
* Fnott now searches for its configuration in
`$XDG_DATA_DIRS/fnott/fnott.ini`, if no configuration is found in
`$XDG_CONFIG_HOME/fnott/fnott.ini` or in `$XDG_CONFIG_HOME/fnottrc`
- (https://codeberg.org/dnkl/fnott/issues/7).
+ ([#7][7]).
* Assume a DPI of 96 if the monitor’s DPI is 0 (seen on certain
emulated displays).
* There is now an empty line between the ‘summary’ and ‘body’.
+[7]: https://codeberg.org/dnkl/fnott/issues/7
+
### Deprecated
* `$XDG_CONFIG_HOME/fnottrc` and `~/.config/fnottrc`. Use
`$XDG_CONFIG_HOME/fnott/fnott.ini` (defaulting to
- `~/.config/fnott/fnott.ini`) instead
- (https://codeberg.org/dnkl/fnott/issues/7).
+ `~/.config/fnott/fnott.ini`) instead ([#7][7]).
+
+[7]: https://codeberg.org/dnkl/fnott/issues/7
### Removed
@@ -160,8 +245,10 @@
* `timeout` option to `fnottrc`. This option can be set on a
per-urgency basis. If both the user has set a timeout, and the
notification provides its own timeout, the shortest one is used
- (https://codeberg.org/dnkl/fnott/issues/2).
-* FreeBSD port (https://codeberg.org/dnkl/fnott/issues/1).
+ ([#2][2]).
+* FreeBSD port ([#1][1]).
+
+[1]: https://codeberg.org/dnkl/fnott/issues/1
### Fixed
diff --git a/PKGBUILD b/PKGBUILD
index 0ad6504a0a10..4ea02a35d862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=fnott
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
pkgdesc="Keyboard driven and lightweight Wayland notification daemon"
arch=('x86_64')
@@ -11,7 +11,7 @@ depends=('dbus' 'fcft' 'wlroots')
makedepends=('meson' 'scdoc' 'wayland-protocols' 'tllist')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('a4e72845cde23aff0653f9b218a32cb40ae628b3f690dc02333ea95469faf216')
+sha256sums=('d17d6a55a7e0d56ddfc3277fbbefa7baf4c70f02265bcb8bd72ee464e202e454')
prepare() {
cd "$pkgname"
@@ -25,5 +25,5 @@ build() {
package() {
DESTDIR="$pkgdir/" meson install -C build
- install -Dm644 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm644 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}