summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-10-08 09:07:46 +0200
committerwillemw122023-10-08 09:07:46 +0200
commitad2e81b77de1408014eb0e1897c0c1f7e1e80bcb (patch)
treeb11f0ae6688837eb1afde242dbcf6c25a39b4617
parent9a52ee7f668f7912a2723ea4c4c70c578db52ac2 (diff)
downloadaur-fnott-git.tar.gz
Cleanup. Merge parts from fnott package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD43
2 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 876f27562db6..a825ad5d00e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = fnott-git
- pkgdesc = Keyboard-driven and lightweight Wayland notification daemon
- pkgver = 1.0.1.r2.g5845372
- pkgrel = 2
+ pkgdesc = Keyboard driven and lightweight Wayland notification daemon
+ pkgver = 1.4.1.r4.g222ca03
+ pkgrel = 1
url = https://codeberg.org/dnkl/fnott
arch = x86_64
license = MIT
makedepends = git
makedepends = meson
makedepends = scdoc
- makedepends = wayland-protocols
makedepends = tllist
+ makedepends = wayland-protocols
depends = dbus
depends = fcft
depends = wlroots
provides = fnott
conflicts = fnott
- source = fnott-git::git+https://codeberg.org/dnkl/fnott
+ source = fnott-git::git+https://codeberg.org/dnkl/fnott.git
md5sums = SKIP
pkgname = fnott-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7e20264e997d..a84e1caf0ace 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
-# Maintainer: lmartinez
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: lmartinez
+
pkgname=fnott-git
-pkgver=1.0.1.r2.g5845372
-pkgrel=2
-pkgdesc="Keyboard-driven and lightweight Wayland notification daemon"
-arch=('x86_64')
-url="https://codeberg.org/dnkl/fnott"
-license=('MIT')
-depends=('dbus' 'fcft' 'wlroots')
-makedepends=('git' 'meson' 'scdoc' 'wayland-protocols' 'tllist')
-provides=('fnott')
-conflicts=('fnott')
-source=("$pkgname::git+$url")
+pkgver=1.4.1.r4.g222ca03
+pkgrel=1
+pkgdesc='Keyboard driven and lightweight Wayland notification daemon'
+arch=(x86_64)
+url=https://codeberg.org/dnkl/fnott
+license=(MIT)
+depends=(dbus fcft wlroots)
+makedepends=(git meson scdoc tllist wayland-protocols)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long | sed 's/-/.r/;s/-/./'
+ git -C $pkgname describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- meson --prefix=/usr --buildtype=release --wrap-mode=nofallback -Db_lto=true build
- ninja -C build
+ arch-meson $pkgname $pkgname/build
+ meson compile -C $pkgname/build
+}
+
+check() {
+ meson test -C $pkgname/build
}
package() {
- cd "$pkgname"
- DESTDIR="$pkgdir/" ninja -C build install
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ meson install -C $pkgname/build --destdir "$pkgdir"
+ install -Dm0644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
}