summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-02-25 20:50:54 -0600
committerLuis Martinez2021-02-25 20:50:54 -0600
commite5819a282078052dc712cc950b1307560bf60cea (patch)
tree554cd0635f8affd3a3e8e8b638958b84eb204068
downloadaur-e5819a282078052dc712cc950b1307560bf60cea.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44899660aff1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fnott-git
+ pkgdesc = Keyboard-driven and lightweight Wayland notification daemon
+ pkgver = 1.0.1.r2.g5845372
+ pkgrel = 1
+ url = https://codeberg.org/dnkl/fnott
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = scdoc
+ makedepends = wayland-protocols
+ makedepends = tllist
+ depends = dbus
+ depends = fcft
+ depends = wlroots
+ provides = fnott
+ conflicts = fnott
+ source = fnott-git::git+https://codeberg.org/dnkl/fnott
+ md5sums = SKIP
+
+pkgname = fnott-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94580c6a6a67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: lmartinez
+pkgname=fnott-git
+pkgver=1.0.1.r2.g5845372
+pkgrel=1
+pkgdesc="Keyboard-driven and lightweight Wayland notification daemon"
+arch=('x86_64')
+url="https://codeberg.org/dnkl/fnott"
+license=('MIT')
+depends=('dbus' 'fcft' 'wlroots')
+makedepends=('git' 'meson' 'scdoc' 'wayland-protocols' 'tllist')
+provides=('fnott')
+conflicts=('fnott')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/-/.r/;s/-/./'
+}
+
+build() {
+ cd "$pkgname"
+ meson --prefix=/usr --buildtype=release --wrap-mode=nofallback -Db_lto=true build
+ ninja -C build
+}
+
+package() {
+ cd "$pkgname"
+ DESTDIR="$pkgdir/" ninja -C build install
+}