summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraur@manjaro2016-08-24 14:03:29 +0200
committeraur@manjaro2016-08-24 14:03:29 +0200
commitb5f46b51ba12b15b296971504924078317aa2a63 (patch)
treef88906b7dd571e694e09ecb21bada4efb03c79da
downloadaur-b5f46b51ba12b15b296971504924078317aa2a63.tar.gz
[4.1-1]
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a23428ca710
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Aug 24 12:03:13 UTC 2016
+pkgbase = fntsample
+ pkgdesc = For making font samples that show Unicode coverage of the font and are similar in appearance to Unicode charts (includes pdfoutline).
+ pkgver = 4.1
+ pkgrel = 1
+ url = http://fntsample.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = cairo
+ depends = fontconfig
+ depends = freetype2
+ depends = glib2
+ depends = pango
+ depends = unicode-character-database
+ depends = perl-pdf-api2
+ depends = perl-libintl-perl
+ source = http://downloads.sourceforge.net/project/fntsample/fntsample/4.1/fntsample-4.1.tar.gz
+ md5sums = 109aab88b4ea4a3a78ca415dff3df6f3
+
+pkgname = fntsample
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..485907c20756
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Felix Schindler <aur at schindlerfmily dot de>
+pkgname=fntsample
+pkgver=4.1
+pkgrel=1
+pkgdesc="For making font samples that show Unicode coverage of the font and are similar in appearance to Unicode charts (includes pdfoutline)."
+url=http://fntsample.sourceforge.net/
+license=(GPL3)
+arch=(i686 x86_64)
+depends=(cairo fontconfig freetype2 glib2 pango unicode-character-database perl-pdf-api2 perl-libintl-perl)
+source=(http://downloads.sourceforge.net/project/fntsample/fntsample/4.1/fntsample-4.1.tar.gz)
+md5sums=('109aab88b4ea4a3a78ca415dff3df6f3')
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ ./configure --prefix=${pkgdir}/usr --with-unicode-blocks=/usr/share/unicode-character-database/Blocks.txt
+
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make install
+
+ sed -i "s;${pkgdir};/;g" ${pkgdir}/usr/bin/pdfoutline
+}