summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthirdwinter2025-03-26 16:57:28 +0800
committerthirdwinter2025-03-26 16:57:28 +0800
commit1aad545db5fb692c34d54a8e4479f526524e962d (patch)
treeabd98a092bcd9e877d05772b899206b0f1376e88
downloadaur-1aad545db5fb692c34d54a8e4479f526524e962d.tar.gz
first commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD45
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fc77ae7fc66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = foamshot
+ pkgdesc = foamshot is wayland screenshot utility build by rust
+ pkgver = v0.1.1
+ pkgrel = 1
+ url = https://github.com/Thirdwinter/foamshot
+ arch = x86_64
+ license = MIT
+ depends = wl-clipboard
+ source = https://github.com/Thirdwinter/foamshot/releases/download/v0.1.1/foamshot-linux-x86_64
+ sha256sums = 2b32b0b1d4c41f34045611ea84a56f98ee0d276575979a2407a7a75853784793
+
+pkgname = foamshot
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c2c6497a6f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: thirdwinter thirdwinters@gmail.com
+pkgname=foamshot
+pkgver=v0.1.1
+pkgrel=1
+epoch=
+pkgdesc="foamshot is wayland screenshot utility build by rust"
+arch=('x86_64')
+url="https://github.com/Thirdwinter/foamshot"
+license=('MIT')
+groups=()
+depends=('wl-clipboard')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/Thirdwinter/foamshot/releases/download/$pkgver/$pkgname-linux-x86_64")
+noextract=()
+sha256sums=("2b32b0b1d4c41f34045611ea84a56f98ee0d276575979a2407a7a75853784793")
+validpgpkeys=()
+
+# prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+# }
+#
+# build() {
+# cd "$pkgname-$pkgver"
+# ./configure --prefix=/usr
+# make
+# }
+#
+# check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+# }
+
+package() {
+ install -Dm755 "$srcdir/$pkgname-linux-x86_64" "$pkgdir/usr/bin/$pkgname"
+}