summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjpfischer2023-10-03 14:20:13 +0000
committerjpfischer2023-10-03 14:20:13 +0000
commit9b1313d2b71f3c33167c539e0dc009bd25577ba3 (patch)
treed58d3f131fee7eb0efe0cf6677894467c53a553b
downloadaur-9b1313d2b71f3c33167c539e0dc009bd25577ba3.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2dc3c9d7138
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = focus-timer-bin
+ pkgdesc = Focus is a cross-platform productivity timer for the command line written in Go.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/ayoisaiah/focus
+ arch = x86_64
+ license = MIT
+ provides = focus
+ conflicts = focus
+ options = !strip
+ source = focus-timer-bin-1.0.0.tar.gz::https://github.com/ayoisaiah/focus/releases/download/v1.0.0/focus_1.0.0_linux_amd64.tar.gz
+ b2sums = 7cd0f33dbbd6bb1d13a7e88eec5445403d486347b18b766ef700af31cb206f3d163dfe2f27566b2ce1cd105ebef38afc4085054e680764b2fefeb110b8eb71fb
+
+pkgname = focus-timer-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..155329ff95c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jan-Philipp Fischer <mail at jpfischer dot de>
+_name=focus
+pkgname=$_name-timer-bin
+pkgver=1.0.0 # renovate: datasource=github-tags depName=ayoisaiah/focus
+pkgrel=1
+pkgdesc="Focus is a cross-platform productivity timer for the command line written in Go."
+arch=('x86_64')
+url="https://github.com/ayoisaiah/$_name"
+license=('MIT')
+provides=($_name)
+conflicts=($_name)
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ayoisaiah/${_name}/releases/download/v${pkgver}/${_name}_${pkgver}_linux_amd64.tar.gz")
+b2sums=('7cd0f33dbbd6bb1d13a7e88eec5445403d486347b18b766ef700af31cb206f3d163dfe2f27566b2ce1cd105ebef38afc4085054e680764b2fefeb110b8eb71fb')
+
+package() {
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+ install -Dm755 "${_name}" "${pkgdir}/usr/bin/${_name}"
+}