summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2015-06-08 14:43:49 +0200
committerFrederic Bezies2015-06-08 14:43:49 +0200
commit96d87d3a057cd6cf5e082fa2baadba5e05ad9b71 (patch)
treecdb6923a7eee2833fee90f96f14a8bd0610b0dc6
downloadaur-96d87d3a057cd6cf5e082fa2baadba5e05ad9b71.tar.gz
initial commit on aur4
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--focuswriter-git.install12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44b9316a948a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.1
+# Thu May 28 18:08:03 UTC 2015
+pkgbase = focuswriter-git
+ pkgdesc = A simple fullscreen word processor
+ pkgver = 1.5.0.65.ge4f6914
+ pkgrel = 1
+ url = http://gottcode.org/focuswriter/
+ install = focuswriter-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = hunspell
+ optdepends = sdl_mixer: typewriter sound effects
+ provides = focuswriter
+ conflicts = focuswriter
+ source = git://github.com/gottcode/focuswriter.git
+ md5sums = SKIP
+
+pkgname = focuswriter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8874d36aeeea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Diego Principe <cdprincipe@at@gmail@dot@com>
+# Contributor: Stefano Bergamini
+
+_pkgname=focuswriter
+pkgname=focuswriter-git
+pkgver=1.5.0.65.ge4f6914
+pkgrel=1
+pkgdesc="A simple fullscreen word processor"
+arch=('i686' 'x86_64')
+url="http://gottcode.org/${_pkgname}/"
+license=('GPL3')
+depends=('qt5-base' 'qt5-multimedia' 'hunspell')
+optdepends=('sdl_mixer: typewriter sound effects')
+makedepends=('git')
+provides=('focuswriter')
+conflicts=('focuswriter')
+install=${pkgname}.install
+source=("git://github.com/gottcode/focuswriter.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --always | sed -e 's|-|.|g' -e 's|v||'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make INSTALL_ROOT="${pkgdir}/" install
+}
diff --git a/focuswriter-git.install b/focuswriter-git.install
new file mode 100644
index 000000000000..6c87527e21eb
--- /dev/null
+++ b/focuswriter-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}