summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-20 14:23:10 -0700
committerMark Wagie2024-01-20 14:23:10 -0700
commitf9ccb5f4fd03181a43bf449426da17fe74e9a729 (patch)
tree23d103936390349d84538d979fe8c25633af7454
parent88bb1bfeddffb64dcc3dcf9251a8817f916de4f0 (diff)
downloadaur-f9ccb5f4fd03181a43bf449426da17fe74e9a729.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98f2ebb1596d..4d88c1da10aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = folder-color-nautilus
pkgrel = 1
url = https://github.com/costales/folder-color
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
makedepends = dpkg
makedepends = python-build
diff --git a/PKGBUILD b/PKGBUILD
index 5d4a7b2da8ae..c51b32c20096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="Change your folder color in Nautilus"
arch=('any')
url="https://github.com/costales/folder-color"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('python-nautilus')
makedepends=('git' 'dpkg' 'python-build' 'python-distutils-extra' 'python-installer'
'python-setuptools' 'python-wheel')
@@ -17,12 +17,12 @@ source=("git+https://github.com/costales/folder-color.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
dpkg-parsechangelog --show-field Version
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
pushd install-scripts
./nautilus.sh GTK4
@@ -32,7 +32,7 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
python -m installer --destdir="$pkgdir" dist/*.whl
install -d "$pkgdir/usr/share/icons"