summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2021-01-16 09:48:39 +0100
committerKrzysztof AS (3ED)2021-01-16 09:48:39 +0100
commite1b6b82e2d0319bd754fef0094dd7dd4b995e372 (patch)
tree18b106960829e3eeae8d70250394108854f96957
downloadaur-e1b6b82e2d0319bd754fef0094dd7dd4b995e372.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD40
-rw-r--r--folder-color-nautilus-git.install12
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2004b1c2054e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = folder-color-nautilus-git
+ pkgdesc = Folder color switcher for nautilus with gnome icon- numix, vibrancy or humanity skin.
+ pkgver = r11.e76d1d9
+ pkgrel = 1
+ url = http://foldercolor.tuxfamily.org/
+ install = folder-color-nautilus-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-distutils-extra
+ makedepends = python-setuptools
+ depends = python-nautilus
+ depends = nautilus
+ optdepends = numix-icon-theme-git: to use with numix theme
+ optdepends = humanity-icon-theme: to use with humanity theme
+ optdepends = vibrancy-colors: to use with vibrancy theme
+ provides = folder-color-nautilus-bzr
+ conflicts = folder-color-nautilus-bzr
+ source = folder-color-nautilus-git::git+https://github.com/costales/folder-color.git
+ sha256sums = SKIP
+
+pkgname = folder-color-nautilus-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62d30f9218cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5651b3f4b3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: 3ED_0 <krzysztofas at protonmail>
+# Contributor: coldBug <coldBug at e.mail dot de>
+
+pkgname=folder-color-nautilus-git
+pkgver=r11.e76d1d9
+pkgrel=1
+pkgdesc="Folder color switcher for nautilus with gnome icon- numix, vibrancy or humanity skin."
+arch=(any)
+url="http://foldercolor.tuxfamily.org/"
+license=(GPL3)
+depends=('python-nautilus' 'nautilus')
+makedepends=('git' 'python-distutils-extra' 'python-setuptools')
+optdepends=(
+ 'numix-icon-theme-git: to use with numix theme'
+ 'humanity-icon-theme: to use with humanity theme'
+ 'vibrancy-colors: to use with vibrancy theme'
+)
+install=$pkgname.install
+source=($pkgname::git+https://github.com/costales/folder-color.git)
+sha256sums=('SKIP')
+
+conflicts=('folder-color-nautilus-bzr')
+provides=('folder-color-nautilus-bzr')
+
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname/install_scripts"
+ ./nautilus.sh
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir"
+}
+
diff --git a/folder-color-nautilus-git.install b/folder-color-nautilus-git.install
new file mode 100644
index 000000000000..8e0563c9a6c3
--- /dev/null
+++ b/folder-color-nautilus-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ nautilus -q
+ gtk-update-icon-cache /usr/share/icons/hicolor/
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}