summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-26 09:23:10 +0100
committerJoan Bruguera2019-03-26 09:23:10 +0100
commit155fe9b211c08fee8dac4f13c6df477c3ee5fcdb (patch)
tree4d09155be78d7403e5c9a09ed00463710c734cb0
parent72f763e50bc84d1c186324367f53aba322fbd508 (diff)
downloadaur-155fe9b211c08fee8dac4f13c6df477c3ee5fcdb.tar.gz
Do not depend on libbsctools's static libraries.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d87497f7c929..ee06752b516f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = folding
pkgdesc = Combined instrumentation and sampling for instantaneous metric evolution with low overhead (from BSC).
pkgver = 1.3.2
- pkgrel = 4
+ pkgrel = 5
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index bf95da54fa4e..d4f223067e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='folding'
pkgdesc='Combined instrumentation and sampling for instantaneous metric evolution with low overhead (from BSC).'
pkgver='1.3.2'
-pkgrel='4'
+pkgrel='5'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('GPL3')
@@ -10,6 +10,22 @@ depends=(boost qt5-base libbsctools r clang)
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
sha512sums=(df54700a1eee506f7b7b8d08f74805d576d1455fe3e31de368d0a98bd3bc7114eef4c32d73462ac9cab2f5a9f273c27cc8538e9cfbf9b044c8ef66d3881a7f3d)
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # WORKAROUND: The configure/make scripts check if static version (.a) of the libbsctools libraries
+ # are installed, and fail to detect libbsctools if they aren't.
+ # Since even if we're going to link against the dynamic version (.so) as is typical in Arch,
+ # hack it up to check for the dynamic version consistently instead
+ sed -i 's/\.a/.so/g' config/libbsctools.m4
+
+ # WORKAROUND: Any this dependency is missing in the automake scripts,
+ # so the make process breaks when running the autoreconf, so add it again
+ echo 'kriger_test_DEPENDENCIES = libkriger.la' >> 'src/interpolate/service-kriger/Makefile.am'
+
+ autoreconf -i -f -I config
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"