summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-12-10 21:09:10 +0100
committerJoan Bruguera2019-12-10 21:09:10 +0100
commit479aad33649344dfbefd089306c78c27ba0959cd (patch)
tree9bddb716b9db5370fc3e618ec6ce6bdcf7733209
parent806b134052118441e6b699c60dcff9c9a1da46c0 (diff)
downloadaur-479aad33649344dfbefd089306c78c27ba0959cd.tar.gz
Upgrade tracking to the latest version. Additionally, change BSC package versioning numbers, in order to include the year in the pkgver. This is to deal with the fact that multiple, different tallbars are routinely released for the same version number. Up until now, this was handled by bumping pkgrel, but this is not the correct way to handle this, since it's not just a rebuild, but just the upstream code changed.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae681eb2f245..4de0e965cad5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = folding
pkgdesc = Combined instrumentation and sampling for instantaneous metric evolution with low overhead (from BSC).
- pkgver = 1.3.2
- pkgrel = 7
+ pkgver = 1.3.2.20180801
+ pkgrel = 1
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a8f12522e838..6896a180e921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname='folding'
pkgdesc='Combined instrumentation and sampling for instantaneous metric evolution with low overhead (from BSC).'
-pkgver='1.3.2'
-pkgrel='7'
+pkgver='1.3.2.20180801'
+pkgrel='1'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('GPL3')
depends=(boost qt5-base libbsctools r clang python)
makedepends=(gcc-fortran)
-source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2"
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
python3-ports.patch)
sha512sums=(df54700a1eee506f7b7b8d08f74805d576d1455fe3e31de368d0a98bd3bc7114eef4c32d73462ac9cab2f5a9f273c27cc8538e9cfbf9b044c8ef66d3881a7f3d
f62af324cfe585605dbdfdb87fa7877cb794ba854c1445193710f22ce3cb92effcfcb7c6b8e32286f927bd0804478580b6358b62f15cba789359862bc0589aa1)
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-${pkgver%.*}"
# WORKAROUND: The configure/make scripts check if static version (.a) of the libbsctools libraries
# are installed, and fail to detect libbsctools if they aren't.
@@ -33,7 +33,7 @@ prepare() {
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-${pkgver%.*}"
# NOTE: The following optional features are NOT enabled:
# * LaTeX documentation
@@ -45,7 +45,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-${pkgver%.*}"
make prefix="$pkgdir/usr/" install