summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2020-04-18 09:45:55 +0200
committerMaxime Gauduin2020-04-18 09:45:55 +0200
commit7aaca990b934f4eea3058f5f87bbfc4b25360209 (patch)
tree3e9209699bc948b62d793c77e948a301385c7604
parent00aee5c0eaedb9e672d957f2f094e6f78d1a0f32 (diff)
downloadaur-7aaca990b934f4eea3058f5f87bbfc4b25360209.tar.gz
wanted by default.target
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rw-r--r--foldingathome.service3
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fdf31462f61..0e487afe8a02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = foldingathome
pkgdesc = A distributed computing project for simulating protein dynamics
pkgver = 7.6.8
- pkgrel = 6
+ pkgrel = 7
url = https://foldingathome.org/
install = foldingathome.install
arch = x86_64
@@ -10,15 +10,16 @@ pkgbase = foldingathome
depends = glibc
depends = zlib
optdepends = cuda: for folding with an NVIDIA GPU
- optdepends = opencl-amd: for folding with a newer AMD GPU
- optdepends = opencl-mesa: for folding with an older AMD GPU
+ optdepends = ocl-icd: for folding with any GPU
+ optdepends = opencl-amd: for folding with an AMD GPU (>= GCN)
+ optdepends = opencl-mesa: for folding with an AMD GPU (< GCN)
optdepends = opencl-nvidia: for folding with an NVIDIA GPU
backup = etc/foldingathome/config.xml
source = https://download.foldingathome.org/releases/public/release/fahclient/debian-stable-64bit/v7.6/fahclient_7.6.8-64bit-release.tar.bz2
source = foldingathome.service
source = GPUs.txt
sha256sums = 588253c0042dcb0a6b97c9e16ccb8189b316df051094be4202881120255e5d31
- sha256sums = 7fbd762d4724c108e7fdb58d4beedd406db9b5930a41e291e681725610bbcf79
+ sha256sums = c6d5fd1072e6f12818c9d9363e416e2bb65331e59add3dd8a99651282e9abb3c
sha256sums = 5944a6df06b42c5edd4e5f0922f16e3f04cb755bd248d0e610c9262f3814aff9
pkgname = foldingathome
diff --git a/PKGBUILD b/PKGBUILD
index ae8ec1a006d1..bbefecf9b70d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=foldingathome
pkgver=7.6.8
-pkgrel=6
+pkgrel=7
pkgdesc='A distributed computing project for simulating protein dynamics'
arch=(x86_64)
url=https://foldingathome.org/
@@ -17,8 +17,9 @@ depends=(
)
optdepends=(
'cuda: for folding with an NVIDIA GPU'
- 'opencl-amd: for folding with a newer AMD GPU'
- 'opencl-mesa: for folding with an older AMD GPU'
+ 'ocl-icd: for folding with any GPU'
+ 'opencl-amd: for folding with an AMD GPU (>= GCN)'
+ 'opencl-mesa: for folding with an AMD GPU (< GCN)'
'opencl-nvidia: for folding with an NVIDIA GPU'
)
backup=(etc/foldingathome/config.xml)
@@ -29,7 +30,7 @@ source=(
GPUs.txt
)
sha256sums=('588253c0042dcb0a6b97c9e16ccb8189b316df051094be4202881120255e5d31'
- '7fbd762d4724c108e7fdb58d4beedd406db9b5930a41e291e681725610bbcf79'
+ 'c6d5fd1072e6f12818c9d9363e416e2bb65331e59add3dd8a99651282e9abb3c'
'5944a6df06b42c5edd4e5f0922f16e3f04cb755bd248d0e610c9262f3814aff9')
package() {
diff --git a/foldingathome.service b/foldingathome.service
index c84b82a9f76d..033dead73377 100644
--- a/foldingathome.service
+++ b/foldingathome.service
@@ -1,5 +1,6 @@
[Unit]
Description=Folding@home distributed computing client
+After=multi-user.target
After=network.target
[Service]
@@ -21,5 +22,5 @@ ExecStartPre=!-/usr/bin/nvidia-modprobe
ExecStartPre=!-/usr/bin/nvidia-modprobe -c 0 -u
[Install]
-WantedBy=multi-user.target
+WantedBy=default.target