summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2017-06-02 11:52:27 +0500
committerDmitry Kharitonov2017-06-02 11:52:27 +0500
commitc09368d7b921f00e05da1ebd011ab221177b5093 (patch)
tree21bd5c89e5bbe9e4f2541edc91ed969fbf7b0306
downloadaur-c09368d7b921f00e05da1ebd011ab221177b5093.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
-rw-r--r--foldingathome.install10
-rw-r--r--foldingathome.service12
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..191e75107ea4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Jun 2 06:52:03 UTC 2017
+pkgbase = foldingathome-beta
+ pkgdesc = Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases - beta version.
+ pkgver = 7.4.16
+ pkgrel = 1
+ url = http://folding.stanford.edu/
+ install = foldingathome.install
+ arch = x86_64
+ license = CUSTOM
+ depends = glibc
+ optdepends = opencl-nvidia: for folding with an nVidia GPU
+ optdepends = cuda: for folding with an nVidia GPU
+ optdepends = opencl-mesa: for folding with an older AMD GPU
+ optdepends = opencl-amd: for folding with a newer AMD GPU
+ conflicts = foldingathome
+ replaces = foldingathome
+ source = https://folding.stanford.edu/releases/beta/release/fahclient/debian-stable-64bit/v7.4/fahclient_7.4.16-64bit-release.tar.bz2
+ source = foldingathome.service
+ sha256sums = dade69e217697dd886a241c4400b9aaef0e16e66f510c33ddcde22cd098fec30
+ sha256sums = ad1bb4f104bc3446db7bb91a7d199bfeda5d80e15e08fe17bc69de1c276e2010
+
+pkgname = foldingathome-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb33cbb43a90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Dmitry Kharitonov <darksab0r at gmail com>
+# Contributor: paul2lv [at] gmail dot com
+
+pkgname=foldingathome-beta
+pkgver=7.4.16
+pkgrel=1
+pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases - beta version."
+arch=('x86_64')
+url="http://folding.stanford.edu/"
+license=('CUSTOM')
+depends=('glibc')
+optdepends=('opencl-nvidia: for folding with an nVidia GPU'
+ 'cuda: for folding with an nVidia GPU'
+ 'opencl-mesa: for folding with an older AMD GPU'
+ 'opencl-amd: for folding with a newer AMD GPU')
+replaces=('foldingathome')
+conflicts=('foldingathome')
+install=foldingathome.install
+source=("https://folding.stanford.edu/releases/beta/release/fahclient/debian-stable-64bit/v7.4/fahclient_${pkgver}-64bit-release.tar.bz2"
+"foldingathome.service")
+sha256sums=('dade69e217697dd886a241c4400b9aaef0e16e66f510c33ddcde22cd098fec30'
+ 'ad1bb4f104bc3446db7bb91a7d199bfeda5d80e15e08fe17bc69de1c276e2010')
+
+# Moronic server
+DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
+
+package() {
+ cd ${srcdir}
+
+ install -D -c -m755 fahclient_${pkgver}-64bit-release/FAHClient ${pkgdir}/opt/fah/FAHClient
+ install -D -c -m755 fahclient_${pkgver}-64bit-release/FAHCoreWrapper ${pkgdir}/opt/fah/FAHCoreWrapper
+ install -D -c -m755 fahclient_${pkgver}-64bit-release/sample-config.xml ${pkgdir}/opt/fah/sample-config.xml
+
+ chmod 755 ${pkgdir}/opt/fah/FAHClient
+ chmod 755 ${pkgdir}/opt/fah/FAHCoreWrapper
+ install -D -m644 fahclient_${pkgver}-64bit-release/copyright ${pkgdir}/usr/share/licenses/${pkgname}/copyright
+ install -D -m644 fahclient_${pkgver}-64bit-release/README ${pkgdir}/opt/fah/README
+ install -D -m644 fahclient_${pkgver}-64bit-release/ChangeLog ${pkgdir}/opt/fah/ChangeLog
+ install -D -m644 ${srcdir}/foldingathome.service ${pkgdir}/usr/lib/systemd/system/foldingathome.service
+}
+
diff --git a/foldingathome.install b/foldingathome.install
new file mode 100644
index 000000000000..d48431453e1f
--- /dev/null
+++ b/foldingathome.install
@@ -0,0 +1,10 @@
+post_install() {
+ cat << 'EOM'
+ --> Please cd to /opt/fah/ and execute ./FAHClient --configure
+ --> as root to configure your settings. If you are using systemd,
+ --> then run "systemctl enable foldingathome.service" to enable
+ --> the folding service. If you would like join the Arch Linux
+ --> team, use team number 45032.
+EOM
+}
+
diff --git a/foldingathome.service b/foldingathome.service
new file mode 100644
index 000000000000..5219a6317ca8
--- /dev/null
+++ b/foldingathome.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Folding@home distributed computing client
+After=network.target
+
+[Service]
+Type=simple
+WorkingDirectory=/opt/fah
+ExecStart=/opt/fah/FAHClient --config /opt/fah/config.xml --exec-directory=/opt/fah --data-directory=/opt/fah
+
+[Install]
+WantedBy=multi-user.target
+