summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchwonder Reismus2019-07-22 18:20:55 +0300
committerSchwonder Reismus2019-07-22 18:20:55 +0300
commit17044862a753cb8e3b1ecdd198737f4d9a18ca24 (patch)
tree6ded61a7c2f4ebe51b6de1f12b26f7858d0a7665
parent5366a87d93b7e128e00976f03a0a1eb83e3f208b (diff)
downloadaur-17044862a753cb8e3b1ecdd198737f4d9a18ca24.tar.gz
Put the variables in quotes
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5fb75efcd6a2..89a2998dd464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,26 +14,26 @@ optdepends=('hyphen: Auto-hyphenation support'
'dictd: Offline dictionary support'
'festival: Text-to-speech support; also voice package needed'
'espeak-ng: Text-to-speech support; also voice package needed')
-source=($pkgname::git+https://github.com/johnfactotum/$pkgname.git)
-provides=($pkgname)
-conflicts=($pkgname-git)
+source=("$pkgname"::git+https://github.com/johnfactotum/"$pkgname".git)
+provides=("$pkgname")
+conflicts=("$pkgname"-git)
sha256sums=('SKIP')
pkgver() {
- cd $srcdir/$pkgname
+ cd "$srcdir"/"$pkgname"
git describe --tags | sed -r 's/('$pkgver').+/\1/'
}
build() {
- cd $srcdir/$pkgname
- git checkout tags/$pkgver
+ cd "$srcdir"/"$pkgname"
+ git checkout tags/"$pkgver"
meson build --prefix=/usr
ninja -C build
}
package() {
- cd $srcdir/$pkgname
- DESTDIR=$pkgdir ninja -C build install
+ cd "$srcdir"/"$pkgname"
+ DESTDIR="$pkgdir" ninja -C build install
cd "$pkgdir"/usr/bin
ln -sv com.github.johnfactotum.Foliate foliate
}