summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten van Gompel2017-01-17 10:41:55 +0100
committerMaarten van Gompel2017-01-17 10:41:55 +0100
commitca18330fc671a80a69ee48e13684cd7f92e7afa9 (patch)
treeeeed1d23e82ef5942ca80665cc6c9da697ff6a33
downloadaur-ca18330fc671a80a69ee48e13684cd7f92e7afa9.tar.gz
v0.5 release
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD30
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cbc98fa3223
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Tue Jan 17 09:41:34 UTC 2017
+pkgbase = foliautils
+ pkgdesc = Tools for working with the FoLiA format, based on libfolia. *NOT* the same as Python package FoLiA-tools!
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://proycon.github.io/folia
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libtool
+ makedepends = autoconf
+ depends = ticcutils
+ depends = ucto>=0.9.4
+ depends = libxml2
+ depends = libfolia>=1.5
+ depends = libexttextcat
+ provides = foliautils
+ conflicts = foliatools
+ conflicts = foliautils
+ options = !libtool
+ source = https://github.com/LanguageMachines/foliautils/archive/v0.5.tar.gz
+ md5sums = 0c2f1e76e3b6ab2029c68e0ba8db4c29
+
+pkgname = foliautils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c5bd3708493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Maarten van Gompel <proycon at anaproy.nl>
+
+pkgname=foliautils
+pkgver=0.5
+pkgrel=1
+pkgdesc="Tools for working with the FoLiA format, based on libfolia. *NOT* the same as Python package FoLiA-tools!"
+arch=('i686' 'x86_64')
+url="http://proycon.github.io/folia"
+license=('GPL')
+depends=('ticcutils' 'ucto>=0.9.4' 'libxml2' 'libfolia>=1.5' 'libexttextcat')
+provides=('foliautils')
+conflicts=('foliatools' 'foliautils')
+makedepends=('libtool' 'autoconf')
+options=(!libtool)
+_gituser="LanguageMachines"
+_gitname="foliautils"
+source=(https://github.com/LanguageMachines/foliautils/archive/v0.5.tar.gz)
+md5sums=(0c2f1e76e3b6ab2029c68e0ba8db4c29)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ bash bootstrap.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}