summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-09-17 21:54:01 +0200
committerhaawda2017-09-17 21:54:01 +0200
commitc46364d5863b6c5aca9b29478c1145275e1b4f97 (patch)
treee1e26091cf5ce9969742467a517b30c006aa50f4
parent22897f2226dc6874ef57c40a4d6892fc8fca7eb1 (diff)
downloadaur-c46364d5863b6c5aca9b29478c1145275e1b4f97.tar.gz
Updated version (20170915 -> 20170917).
Changelog ========= part of raising an exception on out of memory (e5ba4d1) improving handling of babies with no-collector (fc2fb7b) #19: fix aka for builtin libraries (1469b9d) #11: using 60 bit fixnums on 64 bit systems (1ff4286) fix buffer overflow converting a number to a string (164960d) fix gcc warning (29634c1) handle arithmetic-shift correctly on 64 bit platforms (8cc3d70) on 64 bit platforms, use 60 bit fixnums (91829fa) Merge branch 'master' into bignums (a194680) don't use gmp (d0416ec) improve #18 by requiring 3 ctrl-C within roughly a second and adding a message (6e7d392) Merge pull request #17 from wasamasa/unbuffered-standard-error-ports (8879362) better fix for #15: support dumb terminals (cdf3bcf) Don't make standard error ports buffered (e29e4e7) test going between fixnums and bignums (bb1dbee) Merge branch 'master' into bignums (c3772d0) fix #15: support dumb terminals (58ef310) fix #14: read-line doesn't ever return eof-object from console input (908b85d) fix shift of negative signed value (7db78c4) fixes for gcc (850fdcc) make gmp optional (9a0e7a3) fix bignum tests (4169215) fixes for clang (feb6927) fixes for gcc (6c7fe2d) bignum normalization (5bc3421) bignum expt (3c9fbea) bignum divide and remainder (b15ddd9) bignum arithmetic-shift (96e9aae) integer-length (2eb0900) first-set-bit and bit-count (8442eaf) bit-count and integer-length (a9dbb71) bitwise-ior (ca62853) bignum multiply and bitwise-and (61e8317) bignums: add and subtract (b618d0b) use _strdup on windows only (cd4a53f) fixes for 32 bit windows (f80f76b) fixes for windows warnings (2a2e04a) fix gcc warnings (3528328) fix #7: incorrect error message when call make-bytevector with big integer (13a295a) fix #13: when using read-byte-vector on a file, the last bytes of the file are lost (9589df0) fix #12: standard output and error not being flushed on exit due to exception (2f349ec) fix compiler warning (4ab7a06) FFixnum to long_t and FImmediate to ulong_t (9976c76) int_t to long_t and uint_t ulong_t (9a2c6f3) nfc: starting bignum migration (891ea66) nfc: split bignums into a separate file (b8edb94) nfc: have bignum operations return the result (8e4f2ff) add initial support for tracking stack usage (1d6934b) add initial support for tracking process times and object counts (01ac2ca) don't coalesce free blocks into too big a chunks (0a22159) make internal hash tables thread safe (39d9a06) add FWithExclusive for C; like with-exclusive for Scheme (aa2cd38) clean hash tables of broken ephemerons (00a673e) use ephemerons with hash tables (878219a) and more support for hash tables (1d13526) more support for hash tables (4a2d9b3) change from hash trees to hash tables (54464ea) add comparators (3d4e947) change how root objects are handled (cce86a5) cleanup write code (a56a3f6) replace records with builtins in core code (968d2d0) added BuiltinType and Builtin to use it; can be used to replace most uses of records in core code (c60e62c) change BuiltinLibraries to FomentLibraries (e59f613) check that eternal objects only reference other eternal objects (7cf7ee6) make InternSymbol more robust (d29f63d) fixes for OS X (9feb608) fixes for BSD (5adc004) stop complaining about strdup (a27961b) linux fixes (9fb50cf) win64 fixes (c3da1ed) don't use designated field initializers (8a4e80a) fixes to type-map (d4c679c) add type-map (e0bf294) allow <macro use> in <transformer spec> at top level (0ba6371) add Ephemerons (4da2aa2) start of ephemerons (10e72c7) change FObjHdr to allow larger objects (befd765) added srfi-1 (cae9554) fix -I and -A command line options (c421333) eternal primitive names (ce36dd8) eternal primitives (2fe9c78) memory management update (81bd933) set default collector to mark-sweep (7b3e908) identifiers as built in objects rather than records (954d36f) more eternal symbols (bc097f3) eternal objects and symbols (856c6e1) fix printing tags (c0ec93d) add kids generation (1ff37e7) improve heap checking code (9f74531) get rid of PushRoot etc (a6216ac) unix: test-all target to run all tests with all collectors (63485d1) generational collector and trackers (b4c70e5) fix for CheckHeap (6d346ca) config options from command line and at runtime (358f070) config options (f23e4bf) documentation (493a6e5) guardians (a5c3fc8) mark and sweep collector (277b1dc) clean up immediate tags (b50f4f6) null collector (06a0741) NumberP cleanup (ef45c05) get rid of mature two slots (1d3b372) don't special case ratios, complexes, and flonums (22b4376) don't special case pairs (0d55cf9) disable srfi 114 (051c65a) get rid of ValidateGC (4c81124) change from ValidateGC to WalkHeap (c4c70b3) starting to validate heap (b71d8ca) unix: control heap location (51afa3f) make OS X happy (c193d4d) another test commit (52918ac) test commit (d92f2bd) eq hash sets (e2aaa88) groundwork for supporting sets and bags (e7d2b26) mv hashmap.cpp hcontain.cpp (34dc576) add hash containers (aa15f65) check for out of memory (f002eea) fixes (37f2dd8) grow stacks and increase heap size (9e2b73e) 32bit fix for hash trees (d8fe4c3) start of sets (41099e2) windows: use popcount intrinsics (7c06726) profiling and use builtins for population count (44d54e6) make hash-map routines generic (ef3ecca) letrec fix: assign inits to formals in the wrong order (49a42f5) normalize bignum results in truncate-quotient and truncate-remainder (892a687) test hash maps (1da1f2c) unix fixes (ee4bf62) srfi-114 comparators (3af7c26) more comparators (6b6a5b2) hash maps; default comparator (512b08b) linux fixes (4e602d0) fix ceiling (502a8c3) Hashtable to HashMap (1127a96) part of EqHashtable to EqHashMap (513a660) test eq-hash-map-set! (e0fb4d7) misc cleanup (103c293) hash tree fix (065b89c) more hash map (a05b8dc) hash-map (8d27744) array mapped tries (7e04027) bsd fixes (fa7dce1) rearranging source (e610fde) fix compiler warnings with 32bit gcc (6b28ac0) Merge branch 'compiler' of https://code.google.com/p/foment into compiler (49c63f5) rearranging compiler passes (b0da5f7) added anapass (aa2ed05) more cnstpass (3617463) usepass and cnstpass added (cb0a56f) use syntax-rules for case rather than compiler built in (cf009fd) todo list for compiler (28ee3db) added letrec-values and letrec*-values (c37433e) expand to let-values rather than let*-values (5e4112b) todo list for compiler (60fc596) added letrec-values and letrec*-values (d1d5d45) expand to let-values rather than let*-values (b900106) box variables which are set (7910fca) rearranging compiler passes (bcfe763) added anapass (1edf2e4) more cnstpass (8b57c99) usepass and cnstpass added (59c6d89) use syntax-rules for case rather than compiler built in (4a3e353) Merge branch 'compiler' of https://code.google.com/p/foment into compiler (4fa79e3) todo list for compiler (8306eb5) added letrec-values and letrec*-values (f4eb6f6) expand to let-values rather than let*-values (6f09a15) box variables which are set (139be2c) improve error messages (4ff8326) todo list for compiler (166925d) start of work on exceptions (992dcfa) added letrec-values and letrec*-values (4ad98c2) expand to let-values rather than let*-values (38e300a) box variables which are set (c696ae3) don't install a guardian for port used by buffered and translator ports (76e1bd9) added -validate-heap command line switch (80deebc) fix compiler warnings (e22cb30) bug fixes, more heap checking, trackers and guardians updated (07ab6f4) long strings work now (a418888) bug for for LeaveThread (e412e09) turn off some validation code (f508bcf) Merge branch 'master' of https://code.google.com/p/foment (c7db8e9) chase symbolic links on library paths (b8bf276) fixed bug with thread exit and active zero (033305e) bitwise ops on bignums need to allocate a new bignum for the result (5cf7c8a) get rid of SpecialSyntaxMsg (d853b20) bug fix to named let (bb3bfd4) bug with getting directory part of argv[0] for library-path (c92c898) (string->number "") should return #f (7cb0ed5) modifying records was not tracking back references properly (0554798) (begin) as a top-level expression is legal (aece1e3) fix for arithmetic-shift on 32 bit systems (c1e6245) port-position and set-port-position! for linux (e8f0e7c) port-position and set-port-position! (63fc4e0) fix (append) (4d424cb) test fix for unix (d316cde) tests for file system api (344a9e7) file system apis (e6b9bc4) unix: file system pr primitives (ac9f774) unix: file system primitives (afb1482) windows file system primitives (eb00f40) fix named let scoping (a7c6d5c) added a few more tests (8663a01) unix: fix a compiler warning (5cb6024) srfi 60: integers as bits (809348e) more srfi-60 (0f5b48c) partial srfi-60 support (9a0a370) fix scoping of do (41956b1) fix scoping bug in compiler (a064e91) need to flush stdout and stderr on exit (e3fcd68) MakeRatio assumes that the arguments can be modified (962f513) remove unused function (8a22e02) over active assert (6136b97) fix for converting floats to integers (42a24be) scope fix (683106f) scoping fix (67a8e85) allow arbitrary length literal strings (f6b25eb) small fix to compiler (2534ba7) library names can have integers in them; remove some debugging code (88de758) no banner message in program mode (e526814) number->string returns lowercase rather than uppercase (c3bcad6) include, include-ci, and include-library-declarations filenames are relative to including file (e3a50ff) OS X uses MAP_ANON (65d03b1) foment scheme scripts on unix: #!... (5d9d387) makefile fix for unix; empty cond-expand (515a007) use volatile (3c7a90a)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 738d71d6ac13..19e38e9dcebc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Sep 16 04:56:58 UTC 2017
+# Sun Sep 17 19:54:01 UTC 2017
pkgbase = foment-git
pkgdesc = Foment scheme
- pkgver = 20170915
+ pkgver = 20170917
pkgrel = 1
url = https://github.com/leftmike/foment.git
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 1d0d60bc560c..54c157fc7620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: <craven@gmx.net>
pkgname=foment-git
-pkgver=20170915
+pkgver=20170917
pkgrel=1
pkgdesc="Foment scheme"
arch=('i686' 'x86_64')