summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter2016-05-06 08:55:08 +0200
committerPeter2016-05-06 08:55:08 +0200
commitda73cef76c28525b0e6fc48d3e811146a6ff8d64 (patch)
treeeb3919dcc07a0c1d4b3a343932b29642bf95c6db
downloadaur-da73cef76c28525b0e6fc48d3e811146a6ff8d64.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD63
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..439336d45f36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = foment-git
+ pkgdesc = Foment scheme
+ pkgver = 20160506
+ pkgrel = 1
+ url = https://github.com/leftmike/foment.git
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+
+pkgname = foment-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80bc7894ca5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=foment-git
+pkgver=20160506
+pkgrel=1
+pkgdesc="Foment scheme"
+arch=(i686 x86_64)
+url="https://github.com/leftmike/foment.git"
+license=('unknown')
+groups=()
+depends=()
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=()
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+_gitroot=https://github.com/leftmike/foment.git
+_gitname=foment
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ #
+ # BUILD HERE
+ #
+ cd unix
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -D unix/release/foment ${pkgdir}/usr/bin/foment
+}
+
+# vim:set ts=2 sw=2 et: