summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2015-06-08 21:01:24 +0200
committerBjoern Franke2015-06-08 21:01:24 +0200
commit8595d04eedf938ffcd90ab7ad31e6d745b98b345 (patch)
tree192e88f84dd4c37be74db5783caa55659dfe166d
downloadaur-8595d04eedf938ffcd90ab7ad31e6d745b98b345.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..384b7db2942a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fon-flash
+ pkgdesc = A new program based on AP51 flash, for flashing La Fonera and Atheros chipset compatible devices
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://www.gargoyle-router.com/wiki/doku.php?id=fon_flash
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = libpcap
+ source = http://www.gargoyle-router.com/downloads/fon-flash/fon-flash-src.tar.gz
+ md5sums = dd84cd9e0965b73849c588e59c4f139a
+
+pkgname = fon-flash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9db9322ce579
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: onny <onny@project-insanity.org>
+# Contributor: onny <onny@project-insanity.org>
+
+pkgname=fon-flash
+pkgver=0.1
+pkgrel=1
+pkgdesc="A new program based on AP51 flash, for flashing La Fonera and Atheros chipset compatible devices"
+url=('http://www.gargoyle-router.com/wiki/doku.php?id=fon_flash')
+arch=('i686' 'x86_64')
+license=('GPL2')
+makedepends=('libpcap')
+source=("http://www.gargoyle-router.com/downloads/fon-flash/fon-flash-src.tar.gz")
+md5sums=('dd84cd9e0965b73849c588e59c4f139a')
+build () {
+ cd "$srcdir/fon-flash-src"
+ make fon-flash
+}
+package() {
+ cd "$srcdir/fon-flash-src"
+ mkdir -p "$pkgdir/usr/bin"
+ cp fon-flash "$pkgdir/usr/bin/"
+}