summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 08:41:34 +0000
committerAntonio Rojas2021-05-08 08:41:34 +0000
commit7a6830995e7585fa50b5ede35fe799c7d587b173 (patch)
tree80f4c34d41253f3f4bada1be1937ceec62fec017
downloadaur-7a6830995e7585fa50b5ede35fe799c7d587b173.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d5304d9d9e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = font-bh-ttf
+ pkgdesc = X.org Luxi Truetype fonts
+ pkgver = 1.0.3
+ pkgrel = 7
+ url = https://xorg.freedesktop.org/
+ arch = any
+ license = custom
+ makedepends = xorg-util-macros
+ source = https://xorg.freedesktop.org//releases/individual/font/font-bh-ttf-1.0.3.tar.bz2
+ sha256sums = 1b4bea63271b4db0726b5b52c97994c3313b6023510349226908090501abd25f
+
+pkgname = font-bh-ttf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40143764bb71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: Gaetan Bisson <bisson@archlinux.org>
+#Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=font-bh-ttf
+pkgver=1.0.3
+pkgrel=7
+pkgdesc='X.org Luxi Truetype fonts'
+url='https://xorg.freedesktop.org/'
+license=('custom')
+arch=('any')
+makedepends=('xorg-util-macros')
+source=("${url}/releases/individual/font/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('1b4bea63271b4db0726b5b52c97994c3313b6023510349226908090501abd25f')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --with-fontdir=/usr/share/fonts/TTF \
+ --with-fc-confdir=/usr/share/fontconfig \
+ MKFONTSCALE=/bin/true MKFONTDIR=/bin/true
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install \
+ actualconfigdir=/usr/share/fontconfig/conf.default
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
+# vim:set sw=2 et: