summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-25 08:42:29 +0300
committerCaleb Maclennan2020-03-25 08:49:48 +0300
commitda8829ec76c216c097b88c46e55ff198939fb3c3 (patch)
treebc98ded62bef5a5df0a052d876eb0ae20b1a207c
parent7be3e21f91a866960026f878cf81a08324d28a43 (diff)
downloadaur-da8829ec76c216c097b88c46e55ff198939fb3c3.tar.gz
Add pkgrel to downloaded source name to sidestep caching issues
Upstream keeps changing the zip without changing the name or even the version of the font inside, so people are having trouble building this because they 'have' the download but their checksums fail. This forces a new download filename every time we bump the package in the AUR, hence giving users a much better chance of having the right file, not just a file of the same name.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf08db82879a..93d4aff11541 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,8 @@ pkgbase = font-symbola
license = custom
makedepends = fontforge
makedepends = poppler
- source = font-symbola-13.00.zip::https://dn-works.com/wp-content/uploads/2020/UFAS-Fonts/Symbola.zip
- source = https://dn-works.com/wp-content/uploads/2020/UFAS-Docs/License.pdf
+ source = font-symbola-13.00-6.zip::https://dn-works.com/wp-content/uploads/2020/UFAS-Fonts/Symbola.zip
+ source = License-13.00-6.pdf::https://dn-works.com/wp-content/uploads/2020/UFAS-Docs/License.pdf
source = 45-symbola.conf
source = 90-tt-symbola.conf
sha512sums = ba671168ab2dc15293ae404f849f13b9b1f4684ce1856a8c2bbf8b9a2e2d70a27f86ef166a5e3ab6260e651c8276537ee272710a7e1fb49beef26fbed6355a35
diff --git a/PKGBUILD b/PKGBUILD
index d2fa84e5c83c..2d32eee9163b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ arch=('any')
url='https://dn-works.com/ufas/'
license=('custom')
makedepends=('fontforge' 'poppler')
-source=("$pkgbase-$pkgver.zip::https://dn-works.com/wp-content/uploads/2020/UFAS-Fonts/Symbola.zip"
- 'https://dn-works.com/wp-content/uploads/2020/UFAS-Docs/License.pdf'
+source=("$pkgbase-$pkgver-$pkgrel.zip::https://dn-works.com/wp-content/uploads/2020/UFAS-Fonts/Symbola.zip"
+ "License-$pkgver-$pkgrel.pdf::https://dn-works.com/wp-content/uploads/2020/UFAS-Docs/License.pdf"
'45-symbola.conf'
'90-tt-symbola.conf')
sha512sums=('ba671168ab2dc15293ae404f849f13b9b1f4684ce1856a8c2bbf8b9a2e2d70a27f86ef166a5e3ab6260e651c8276537ee272710a7e1fb49beef26fbed6355a35'
@@ -27,7 +27,7 @@ sha512sums=('ba671168ab2dc15293ae404f849f13b9b1f4684ce1856a8c2bbf8b9a2e2d70a27f8
build() {
fontforge -c 'open(argv[1]).generate(argv[2])' Symbola.{otf,ttf}
- pdftotext License.pdf LICENSE
+ pdftotext "${source[1]%::*}" LICENSE
}
package_otf-symbola() {