summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-04 00:54:22 +0300
committerCaleb Maclennan2023-05-04 00:54:22 +0300
commitb44971585a53b67268bf9ffaf8ef16c251446dac (patch)
tree4ca99d3ff4cee1dd648546b6fe04c51a2d718747
parent586d6ecfa2d0ddd97afe5ccb0ea2e7351a50de7b (diff)
downloadaur-b44971585a53b67268bf9ffaf8ef16c251446dac.tar.gz
upgpkg: font-v 2.1.0-2
Rebuild for Python 3.11, normalize PEP517 build tooling
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e0132f79e59..432792ab2ae2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = font-v
pkgdesc = Font version string reporting and modification library + executable tool
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/source-foundry/font-v
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
depends = python-gitpython
diff --git a/PKGBUILD b/PKGBUILD
index e71ffe819986..b29a7550c3ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=font-v
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Font version string reporting and modification library + executable tool'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
@@ -10,17 +10,18 @@ license=(MIT)
depends=(python
python-gitpython
python-fonttools)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$pkgname-$pkgver"
source=("$_archive.tgz::$url/archive/v$pkgver.tar.gz")
sha256sums=('c8f36e1413a94cd58f64e519681be12e019d78dd9a5baa2318a9499fd7b0f63e')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}