summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadoslaw Mejer2019-06-22 09:44:14 +0200
committerRadoslaw Mejer2019-06-22 09:44:14 +0200
commit0deb1f7ec186b6c1ad5b9a36242a8c60bce022f1 (patch)
treefbff2a7f2fd1e5c7221afe42232b4c4304fc57b1
downloadaur-0deb1f7ec186b6c1ad5b9a36242a8c60bce022f1.tar.gz
Repo init
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--Makefile5
-rw-r--r--PKGBUILD21
4 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a61683e3c802
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = font-victor-mono
+ pkgdesc = A programming font with cursive italics and ligatures.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/rubjo/victor-mono
+ arch = any
+ source = https://github.com/rubjo/victor-mono/raw/v1.1.0/public/VictorMonoAll.zip
+ sha256sums = 9275f581dc2fd0d14d152de7be0e3eaefbb9379a4a497c691e8fcd8b5bf748c4
+
+pkgname = font-victor-mono
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4db48576517b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!Makefile
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..a1451de8802d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,5 @@
+.PHONY: all
+all: .SRCINFO
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daa882f401a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname="font-victor-mono"
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A programming font with cursive italics and ligatures."
+arch=(any)
+url="https://github.com/rubjo/victor-mono"
+source=(
+ "https://github.com/rubjo/victor-mono/raw/v$pkgver/public/VictorMonoAll.zip"
+)
+sha256sums=(
+ "9275f581dc2fd0d14d152de7be0e3eaefbb9379a4a497c691e8fcd8b5bf748c4"
+)
+
+package() {
+ cd "$srcdir"
+
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 TTF/*.ttf
+ install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+