summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrasjet2021-06-30 15:11:13 +0000
committerkrasjet2021-06-30 15:11:13 +0000
commitd9ced3b9ab95ca07b6ca1bf2a9d4e162a89a9752 (patch)
tree4acf1e5e9b48a52632e339dfcef2f3a1f0f357ae
parent7eeed37d48d0244faf527658fb99df550a29c57b (diff)
downloadaur-d9ced3b9ab95ca07b6ca1bf2a9d4e162a89a9752.tar.gz
fix missing files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7bbb91c98e4..b457972e0ca0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = fontbase
pkgdesc = FontBase is the font manager of the new generation, built by designers, for designers.
pkgver = 2.16.0
- pkgrel = 1
+ pkgrel = 2
url = https://fontba.se/
arch = x86_64
arch = i686
license = custom:FontBase
makedepends = p7zip
- depends = electron11
+ depends = electron
source = fontbase-2.16.0.AppImage::https://releases.fontba.se/linux/FontBase-2.16.0.AppImage
md5sums = 10b5f8e86ec67c27f9666eaee5f723e9
diff --git a/PKGBUILD b/PKGBUILD
index 130d2a480e79..d7f7d1ea3e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Bruce Zhang krasjet
pkgname=fontbase
pkgver=2.16.0
-pkgrel=1
+pkgrel=2
pkgdesc="FontBase is the font manager of the new generation, built by designers, for designers."
arch=('x86_64' 'i686')
url="https://fontba.se/"
license=('custom:FontBase')
-depends=('electron11')
+depends=('electron')
makedepends=('p7zip')
source=("$pkgname-$pkgver.AppImage::https://releases.fontba.se/linux/FontBase-$pkgver.AppImage")
md5sums=('10b5f8e86ec67c27f9666eaee5f723e9')
@@ -16,21 +16,20 @@ prepare() {
cd "$srcdir/$pkgname"
7z x "$srcdir/$pkgname-$pkgver.AppImage"
echo "https://fontba.se/legal/terms" > "$srcdir/COPYRIGHT"
-
- sed -i 's/Exec=AppRun/Exec=fontbase/' fontbase-app.desktop
}
package() {
cd "$srcdir/$pkgname"
# Install application
- install -Dm644 resources/app.asar "$pkgdir/usr/share/fontbase/app.asar"
- cd resources/plugins
+ cd resources/app
+ find . -type f -exec install -Dm644 {} "$pkgdir/usr/share/fontbase/app/{}" \;
+ cd ../plugins
find . -type f -exec install -Dm644 {} "$pkgdir/usr/share/fontbase/plugins/{}" \;
# Install start script
echo "#!/usr/bin/env sh
-exec electron11 /usr/share/fontbase/app.asar \$@
+exec electron /usr/share/fontbase/app/ \$@
" > "$srcdir/fontbase.sh"
install -Dm755 "$srcdir/fontbase.sh" "$pkgdir/usr/bin/fontbase"