summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicoHood2016-11-11 21:36:50 +0100
committerNicoHood2016-11-11 21:36:50 +0100
commitcf902bddcffbacff3762a319f23a9c202bbd9030 (patch)
tree3f58475347ddf91f8f186722528e66de14b0bbce
downloadaur-cf902bddcffbacff3762a319f23a9c202bbd9030.tar.gz
Initital commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD27
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebbb5ca6cda3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fontbuilder
+ pkgdesc = Utility for create texture atlases with bitmap chars from FreeType,TrueType and some other font formats.
+ pkgver = 0.6a.r1.fe0d7cf
+ pkgrel = 1
+ url = https://github.com/andryblack/fontbuilder
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = qt5-base
+ source = LICENSE
+ source = fontbuilder-0.6a.r1.fe0d7cf.tar.gz::https://github.com/andryblack/fontbuilder/archive/fe0d7cf759af86288ea2c59a9d33518535546245.tar.gz
+ sha512sums = 92725921a2706d66431ab3e357e4b49aa2c713a783885ac06a0a4000bb0e38b063a8dd5b04531a7f59d7e98e90e446ab1240d3f4690cfe4824e26bf25bac7431
+ sha512sums = 122a08f9544b8cfb46520ed197c8ed780919095779251282cd6f88e2816ccdbcfe728b1edee4b3a762fe710f891e9a700bd0a074952c12301f30ad75f084dd1d
+
+pkgname = fontbuilder
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3ce481d494aa
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+/**
+ * Copyright (c) 2010-2010 Andrey AndryBlack Kunitsyn
+ * email:support.andryblack@gmail.com
+ *
+ * Report bugs and download new versions at http://code.google.com/p/fontbuilder
+ *
+ * This software is distributed under the MIT License.
+ *
+ * Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or sell
+ * copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7036f5bfc827
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: NicoHood <aur {at} nicohood {dot} de>
+# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+
+pkgname=fontbuilder
+pkgver=0.6a.r1.fe0d7cf
+_commit=fe0d7cf759af86288ea2c59a9d33518535546245
+pkgrel=1
+pkgdesc="Utility for create texture atlases with bitmap chars from FreeType,TrueType and some other font formats."
+arch=('x86_64' 'i686')
+url="https://github.com/andryblack/fontbuilder"
+license=('MIT')
+depends=('qt5-base')
+source=('LICENSE'
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/andryblack/${pkgname}/archive/${_commit}.tar.gz")
+sha512sums=('92725921a2706d66431ab3e357e4b49aa2c713a783885ac06a0a4000bb0e38b063a8dd5b04531a7f59d7e98e90e446ab1240d3f4690cfe4824e26bf25bac7431'
+ '122a08f9544b8cfb46520ed197c8ed780919095779251282cd6f88e2816ccdbcfe728b1edee4b3a762fe710f891e9a700bd0a074952c12301f30ad75f084dd1d')
+
+build() {
+ cd "${pkgname}-${_commit}"
+ qmake
+ make
+}
+
+package() {
+ install -Dm755 "${pkgname}-${_commit}/bin/FontBuilder" "${pkgdir}/usr/bin/fontbuilder"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}