summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-02-27 20:06:50 -0500
committerVincent Grande2021-02-27 20:06:50 -0500
commit26e46b635acfa5c705661196e99db7af95cbc89d (patch)
tree486bf8e52274460d2795ee5d4c4a9b80c46ca76f
downloadaur-26e46b635acfa5c705661196e99db7af95cbc89d.tar.gz
initial upload
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD70
-rw-r--r--fontconfig.hook11
-rw-r--r--fontconfig.install12
4 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c32ede375cd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = fontconfig-minimal-git
+ pkgdesc = Library for configuring and customizing font access
+ pkgver = 2.13.91+48+gfcb0420
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/fontconfig/
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = autoconf-archive
+ makedepends = gperf
+ makedepends = python-lxml
+ makedepends = python-six
+ makedepends = json-c
+ makedepends = expat
+ makedepends = freetype2
+ optdepends = docbook-utils: docs
+ optdepends = docbook-sgml: docs
+ source = git+https://gitlab.freedesktop.org/fontconfig/fontconfig.git
+ source = fontconfig.hook
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = fontconfig-minimal-git
+ install = fontconfig.install
+ depends = expat
+ depends = libfreetype.so
+ provides = libfontconfig.so
+ provides = fontconfig
+ conflicts = fontconfig
+ backup = etc/fonts/fonts.conf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22135af0fd5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=(fontconfig-minimal-git)
+pkgver=2.13.91+48+gfcb0420
+pkgrel=1
+#epoch=1
+pkgdesc="Library for configuring and customizing font access"
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
+arch=(x86_64)
+license=(custom)
+makedepends=(git autoconf-archive gperf python-lxml python-six json-c expat freetype2)
+optdepends=('docbook-utils: docs'
+ 'docbook-sgml: docs')
+#checkdepends=(unzip)
+source=("git+https://gitlab.freedesktop.org/fontconfig/fontconfig.git"
+ fontconfig.hook)
+sha256sums=('SKIP'
+ 'SKIP')
+
+# a nice page to test font matching:
+# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
+# http://getemoji.com/
+
+pkgver() {
+ cd fontconfig
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd fontconfig
+}
+
+build() {
+ arch-meson fontconfig build \
+ -D doc=false \
+ -D doc-txt=false \
+ -D doc-man=false \
+ -D doc-pdf=false \
+ -D doc-html=false \
+ -D tests=false
+ meson compile -C build
+}
+
+#check() {
+# cd fontconfig
+# meson test -C build
+#}
+
+package_fontconfig-minimal-git() {
+ depends=(expat libfreetype.so)
+ provides=(libfontconfig.so fontconfig)
+ conflicts=(fontconfig)
+ install=fontconfig.install
+ backup=(etc/fonts/fonts.conf)
+
+ cd fontconfig
+ DESTDIR="$pkgdir" meson install -C build
+
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../*.hook
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
+
+ # Split -docs
+# mkdir -p "$srcdir/doc/usr/share/man"
+# mv {"$pkgdir","$srcdir"/doc}/usr/share/doc
+# mv {"$pkgdir","$srcdir"/doc}/usr/share/man/man3
+}
+
+# vim:set sw=2 et:
diff --git a/fontconfig.hook b/fontconfig.hook
new file mode 100644
index 000000000000..63be791decaf
--- /dev/null
+++ b/fontconfig.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = Path
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/fonts/*
+
+[Action]
+Description = Updating fontconfig cache...
+When = PostTransaction
+Exec = /usr/bin/fc-cache -s
diff --git a/fontconfig.install b/fontconfig.install
new file mode 100644
index 000000000000..52bd289fa5ef
--- /dev/null
+++ b/fontconfig.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ # a full forced directory scan is required here
+ echo -n "Rebuilding fontconfig cache..."
+ /usr/bin/fc-cache -rs
+ echo " done."
+}
+
+post_install() {
+ post_upgrade $1 0
+}
+
+# vim:set sw=2 et: