summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-07-13 23:23:52 +0300
committerDet2015-07-13 23:23:52 +0300
commit1561dd68cd9fe2a1d053a894971ca810ec2e8dac (patch)
tree39b940f7f128ed10e3613be6a51bbe0d44250f15
parent37fbb380030293af82ad8c094228afc3a46046bc (diff)
downloadaur-1561dd68cd9fe2a1d053a894971ca810ec2e8dac.tar.gz
Fix end of package()
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10a153f3f728..071733f80655 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,10 +11,13 @@ pkgbase = fontconfig-ubuntu
depends = freetype2-ubuntu
provides = fontconfig=2.11.1
conflicts = fontconfig
+ options = !libtool
source = https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_2.11.1.orig.tar.bz2
source = https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_2.11.1-0ubuntu6.debian.tar.xz
source = 53-monospace-lcd-filter.patch
- options = !libtool
+ md5sums = 824d000eb737af6e16c826dd3b2d6c90
+ md5sums = 5d8e082f4d36d6c82853f6b6a5f6997a
+ md5sums = a17e48be6a06bc056574be6756cb9738
pkgname = fontconfig-ubuntu
diff --git a/PKGBUILD b/PKGBUILD
index 4c49cc8301bf..8621f5dcc4e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,10 +38,10 @@ build() {
cd fontconfig-$pkgver
# make sure there's no rpath trouble and sane .so versioning - FC and Gentoo do this as well
- msg2 "Running 'libtoolize'.."
+ msg2 "Running libtoolize.."
libtoolize -f
- msg2 "Running 'autoreconf'.."
+ msg2 "Running autoreconf.."
autoreconf -fi
# Enable Position Independent Code for prelinking
@@ -57,19 +57,19 @@ build() {
--with-default-fonts=/usr/share/fonts \
--with-add-fonts=/usr/share/fonts
- msg2 "Running 'make'.."
+ msg2 "Running make.."
make
}
package() {
cd fontconfig-$pkgver
- msg2 "Running 'make install'.."
+ msg2 "Running make install.."
make DESTDIR="$pkgdir" install
# License
install -Dm0644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
# Docs
- install -Dm0644 debian/changelog "$pkgdir"/usr/share/doc/fontconfig/changelog
+ install -Dm0644 ../debian/changelog "$pkgdir"/usr/share/doc/fontconfig/changelog
}