summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-06-16 10:25:53 +0000
committerDaniel Bermond2018-06-16 10:25:53 +0000
commit176dc446b923389783b460c50f88b3ca2238366c (patch)
tree622139a59a8f0e3154d6d9de3f838dcea23d0191
parent5607ef488dfdea90732a16f5cdb7f4ce7991ce18 (diff)
downloadaur-176dc446b923389783b460c50f88b3ca2238366c.tar.gz
Updated to version 2.12.6-0ubuntu2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD101
-rw-r--r--fontconfig-ubuntu.hook11
-rw-r--r--fontconfig-ubuntu.install12
4 files changed, 84 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a21ac74272e..f194a1c62561 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,33 @@
pkgbase = fontconfig-ubuntu
- pkgdesc = Library for configuring and customizing font access - with Ubuntu's patches
+ pkgdesc = A library for configuring and customizing font access (with Ubuntu patches)
pkgver = 2.12.6
pkgrel = 1
url = https://launchpad.net/ubuntu/+source/fontconfig
install = fontconfig-ubuntu.install
+ arch = i686
arch = x86_64
license = custom
- makedepends = python2
- makedepends = docbook2x
+ makedepends = autoconf-archive
makedepends = gperf
+ makedepends = python-lxml
+ makedepends = python-six
+ makedepends = docbook-utils
+ makedepends = docbook-sgml
+ makedepends = perl-sgmls
+ makedepends = texlive-formatsextra>=2017
+ makedepends = lynx
depends = expat
depends = freetype2
provides = fontconfig=2.12.6
conflicts = fontconfig
- options = !libtool
source = https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_2.12.6.orig.tar.bz2
- source = https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_2.12.6-0ubuntu1.debian.tar.xz
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_2.12.6-0ubuntu2.debian.tar.xz
source = 53-monospace-lcd-filter.patch
+ source = fontconfig-ubuntu.hook
sha256sums = cf0c30807d08f6a28ab46c61b8dbd55c97d2f292cf88f3a07d3384687f31f017
- sha256sums = 6e44e884856924986ec3637cc38d0a759934d4d065ffd65fa25dd8c9d36bc844
+ sha256sums = 75c259e2d6b1944fe76a49f89b806b3ee34fe7a42eb25efd289e38b1b5e16517
sha256sums = c759702ba66fe88768aa93035637401085bb5c02d898c960b68291aea10daa8d
+ sha256sums = 672f6a1c5e164671955ce807e670306194142a1794ce88df653aa717a972e274
pkgname = fontconfig-ubuntu
diff --git a/PKGBUILD b/PKGBUILD
index 2a22d6fb7d63..49484211c962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,71 +1,78 @@
-# Maintainer: Det
-# Contributors: Joris Steyn, Florian Dejonckheere, Tevin Zhang, Andrea Fagiani, Biru Ionut, Paul Bredbury
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Det
+# Contributor: Joris Steyn, Florian Dejonckheere, Tevin Zhang, Andrea Fagiani, Biru Ionut, Paul Bredbury
# Installation order: freetype2 → fontconfig-ubuntu → cairo-ubuntu
+_srcname=fontconfig
+_ubver=0ubuntu2
+
pkgname=fontconfig-ubuntu
pkgver=2.12.6
-_ubver=0ubuntu1
pkgrel=1
-pkgdesc="Library for configuring and customizing font access - with Ubuntu's patches"
-arch=('x86_64')
-url="https://launchpad.net/ubuntu/+source/fontconfig"
+pkgdesc='A library for configuring and customizing font access (with Ubuntu patches)'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/ubuntu/+source/fontconfig'
license=('custom')
depends=('expat' 'freetype2')
-makedepends=('python2' 'docbook2x' 'gperf')
+makedepends=('autoconf-archive' 'gperf' 'python-lxml' 'python-six' 'docbook-utils' 'docbook-sgml'
+ 'perl-sgmls' 'texlive-formatsextra>=2017' 'lynx')
+provides=("fontconfig=${pkgver}")
conflicts=('fontconfig')
-provides=("fontconfig=$pkgver")
-options=('!libtool')
-install=$pkgname.install
+install="${pkgname}.install"
source=("https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_$pkgver.orig.tar.bz2"
"https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_$pkgver-$_ubver.debian.tar.xz"
- '53-monospace-lcd-filter.patch')
+ '53-monospace-lcd-filter.patch'
+ 'fontconfig-ubuntu.hook')
sha256sums=('cf0c30807d08f6a28ab46c61b8dbd55c97d2f292cf88f3a07d3384687f31f017'
- '6e44e884856924986ec3637cc38d0a759934d4d065ffd65fa25dd8c9d36bc844'
- 'c759702ba66fe88768aa93035637401085bb5c02d898c960b68291aea10daa8d')
+ '75c259e2d6b1944fe76a49f89b806b3ee34fe7a42eb25efd289e38b1b5e16517'
+ 'c759702ba66fe88768aa93035637401085bb5c02d898c960b68291aea10daa8d'
+ '672f6a1c5e164671955ce807e670306194142a1794ce88df653aa717a972e274')
# nice pages to test font matching:
# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
# http://getemoji.com/
prepare() {
- cd fontconfig-$pkgver
-
- # Loop Debian patches
- for _f in $(cat ../debian/patches/series); do
- msg2 "Applying Debian patch: $_f"
- patch -Np1 -i "../debian/patches/$_f"
- done
-
- ## patch
- #patch -p1 -i conf.d/53-monospace-lcd-filter.conf ../53-monospace-lcd-filter.patch
+ cd "${_srcname}-${pkgver}"
+
+ # apply Debian patches
+ for _patch in $(cat "${srcdir}/debian/patches/series")
+ do
+ msg2 "Applying Debian patch: ${_patch}"
+ patch -Np1 -i "${srcdir}/debian/patches/${_patch}"
+ done
+
+ ## patch
+ #patch -p1 -i conf.d/53-monospace-lcd-filter.conf ../53-monospace-lcd-filter.patch
}
build() {
- cd fontconfig-$pkgver
-
- msg2 "Running ./configure.."
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --with-templatedir=/etc/fonts/conf.avail \
- --with-xmldir=/etc/fonts \
- --localstatedir=/var \
- --disable-static \
- --with-default-fonts=/usr/share/fonts \
- --with-add-fonts=/usr/share/fonts
-
- msg2 "Running make.."
- make
+ cd "${_srcname}-${pkgver}"
+
+ ./configure \
+ --prefix='/usr' \
+ --sysconfdir='/etc' \
+ --with-templatedir='/etc/fonts/conf.avail' \
+ --with-xmldir='/etc/fonts' \
+ --localstatedir='/var' \
+ --disable-static \
+ --with-default-fonts='/usr/share/fonts' \
+ --with-add-fonts='/usr/share/fonts'
+
+ make
}
package() {
- cd fontconfig-$pkgver
-
- msg2 "Running 'make install'.."
- make DESTDIR="$pkgdir" install
-
- # License
- install -Dm0644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
-
- # Docs
- install -Dm0644 ../debian/changelog "$pkgdir"/usr/share/doc/fontconfig/changelog
+ cd "${_srcname}-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+
+ # pacman hook
+ install -D -m644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/fontconfig.hook"
+
+ # license
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Debian changelog
+ install -D -m644 "${srcdir}/debian/changelog" "${pkgdir}/usr/share/doc/fontconfig/changelog"
}
diff --git a/fontconfig-ubuntu.hook b/fontconfig-ubuntu.hook
new file mode 100644
index 000000000000..0f24bc4e86f2
--- /dev/null
+++ b/fontconfig-ubuntu.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/fonts/*
+
+[Action]
+Description = Updating fontconfig cache...
+When = PostTransaction
+Exec = /usr/bin/fc-cache -s
diff --git a/fontconfig-ubuntu.install b/fontconfig-ubuntu.install
index 961bba5bb70d..085b26c48716 100644
--- a/fontconfig-ubuntu.install
+++ b/fontconfig-ubuntu.install
@@ -18,16 +18,14 @@ post_install() {
_EOF
- echo -n "updating font cache... "
- # a full forced directory scan is required here
- /usr/bin/fc-cache -f
- echo "done."
+ post_upgrade $1
}
post_upgrade() {
- echo -n "updating font cache... "
- /usr/bin/fc-cache -f
- echo "done."
+ echo -n "Rebuilding fontconfig cache..."
+ # a full forced directory scan is required here
+ /usr/bin/fc-cache -rs
+ echo " done."
}
post_remove() {