summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-19 16:41:46 +0000
committerDaniel Bermond2018-11-19 16:41:46 +0000
commitb28db5c24d8bcf6c6b0c256ee15402a355e7a533 (patch)
tree5aac7ec9bab91c5e01d04779d1f4f8c11c13e226
parent480100c06056e9b4962b6dc12b5194c2396f9db2 (diff)
downloadaur-b28db5c24d8bcf6c6b0c256ee15402a355e7a533.tar.gz
Improve patch applying method
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c401e0886c85..acffa274ddc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fontconfig-ubuntu
pkgdesc = A library for configuring and customizing font access (with Ubuntu patches)
pkgver = 2.13.0
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/ubuntu/+source/fontconfig
install = fontconfig-ubuntu.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b0ac43db2fc6..8f8b7c192b9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@
# http://getemoji.com/
_srcname=fontconfig
-_ubver=5ubuntu3
+_ubuver=5ubuntu3
pkgname=fontconfig-ubuntu
pkgver=2.13.0
-pkgrel=1
+pkgrel=2
pkgdesc='A library for configuring and customizing font access (with Ubuntu patches)'
arch=('i686' 'x86_64')
url='https://launchpad.net/ubuntu/+source/fontconfig'
@@ -24,7 +24,7 @@ provides=("fontconfig=${pkgver}")
conflicts=('fontconfig')
install="${pkgname}.install"
source=("https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_${pkgver}.orig.tar.bz2"
- "https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_${pkgver}-${_ubver}.debian.tar.xz"
+ "https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_${pkgver}-${_ubuver}.debian.tar.xz"
'53-monospace-lcd-filter.patch'
'fontconfig-ubuntu.hook')
sha256sums=('91dde8492155b7f34bb95079e79be92f1df353fcc682c19be90762fd3e12eeb9'
@@ -38,11 +38,14 @@ prepare() {
local _patch
# apply Debian patches
- for _patch in $(cat "${srcdir}/debian/patches/series" | grep '\.patch$\|\.diff$')
+ while read _patch
do
- printf '%s\n' " -> Applying Debian patch: ${_patch}"
- patch -Np1 -i "${srcdir}/debian/patches/${_patch}"
- done
+ if printf '%s' "$_patch" | grep -q '\.patch$\|\.diff$'
+ then
+ printf '%s\n' " -> Applying Debian patch: ${_patch}"
+ patch -Np1 -i "${srcdir}/debian/patches/${_patch}"
+ fi
+ done < "${srcdir}/debian/patches/series"
## patch
#patch -p1 -i conf.d/53-monospace-lcd-filter.conf ../53-monospace-lcd-filter.patch
@@ -70,11 +73,11 @@ package() {
make DESTDIR="$pkgdir" install
# pacman hook
- install -D -m644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/fontconfig.hook"
+ install -D -m644 "${srcdir}/${pkgname}.hook" -t "${pkgdir}/usr/share/libalpm/hooks"
# license
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Debian changelog
- install -D -m644 "${srcdir}/debian/changelog" "${pkgdir}/usr/share/doc/fontconfig/changelog"
+ install -D -m644 "${srcdir}/debian/changelog" -t "${pkgdir}/usr/share/doc/${pkgname}"
}