summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwallace2020-02-05 18:14:33 +0900
committerwallace2020-02-05 18:14:33 +0900
commit70d839f6012ebbd321d33999d4067a00bdc04e24 (patch)
tree9d40fcfe6f8941d4005ab90f7d0404f36ae44062
downloadaur-70d839f6012ebbd321d33999d4067a00bdc04e24.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7954a478b5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fontfor
+ pkgdesc = Find fonts which can show a specified character and preview them in terminal or browser.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/7sDream/fontfor
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = rust
+ source = https://github.com/7sDream/fontfor/archive/v0.2.1.tar.gz
+ sha256sums = 6cce63781393b476a83648a42453ea050e82e7432c3d6f07f1d3e3daddc39166
+
+pkgname = fontfor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4188d4534861
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: wallace < str(11) + my_id at gmail dot com>
+
+pkgname=fontfor
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Find fonts which can show a specified character and preview them in terminal or browser."
+arch=('x86_64')
+url=https://github.com/7sDream/fontfor
+license=('GPL-3.0')
+depends=()
+makedepends=('rust')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('6cce63781393b476a83648a42453ea050e82e7432c3d6f07f1d3e3daddc39166')
+
+build() {
+ cd $pkgname-$pkgver
+ cargo build --release --locked
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dt "$pkgdir"/usr/bin target/release/$pkgname
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}