summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-01-17 22:57:17 -0500
committerChris Severance2019-01-17 22:57:17 -0500
commitd6d02dd3d5b1169f63de76dbc18c3d487fc39a7c (patch)
treeb6c072b8b392ecb6609d001b1e733a04bae93cf1
parentce7080ac663bad153ce33d542ee602b59aa066a4 (diff)
downloadaur-d6d02dd3d5b1169f63de76dbc18c3d487fc39a7c.tar.gz
autu: Update to 0.6.0.r174.g8108e6e-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD54
2 files changed, 39 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c676ec926e0..384104244c0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Jun 9 18:43:36 UTC 2016
+# Fri Jan 18 03:57:17 UTC 2019
pkgbase = fontmatrix-git
pkgdesc = Font manager for Linux
- pkgver = 1177.33cc6af
- pkgrel = 2
- url = http://oep-h.com/fontmatrix/
+ pkgver = 0.6.0.r174.g8108e6e
+ pkgrel = 1
+ url = https://github.com/fontmatrix-git/fontmatrix-git
arch = i686
arch = x86_64
license = GPL
@@ -12,9 +12,9 @@ pkgbase = fontmatrix-git
makedepends = git
makedepends = mesa
depends = qtwebkit
- provides = fontmatrix
+ provides = fontmatrix=0.6.0
conflicts = fontmatrix
- source = git+https://github.com/popolon/fontmatrix.git
+ source = git+https://github.com/fontmatrix/fontmatrix.git
sha256sums = SKIP
pkgname = fontmatrix-git
diff --git a/PKGBUILD b/PKGBUILD
index 0904c00e6df6..401b3f0d61eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,58 @@
+# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
+# Contributor: Bernhard Landauer <oberon@manjaro.org>
# Contributor: Maxime Gauduin <alucryd@gmail.com>
# Contributor: Chebotarev Sergey <sachebotarev@gmail.com>
# Contributor: Aurélien Desbrières <ice.cube@gmx.com>
-# Maintainer: Stefan Husmann <Stefan-Husmann@t-online.de>
+# Contributor: Stefan Husmann <Stefan-Husmann@t-online.de>
-pkgname=fontmatrix-git
-pkgver=1177.33cc6af
-pkgrel=2
+set -u
+pkgname='fontmatrix-git'
+pkgver=0.6.0.r174.g8108e6e
+pkgrel=1
pkgdesc='Font manager for Linux'
arch=('i686' 'x86_64')
-url='http://oep-h.com/fontmatrix/'
+#url='http://oep-h.com/fontmatrix/'
+url="https://github.com/${pkgname}/${pkgname}"
license=('GPL')
depends=('qtwebkit')
-conflicts=('fontmatrix')
-provides=('fontmatrix')
makedepends=('cmake' 'git' 'mesa')
-source=('git+https://github.com/popolon/fontmatrix.git')
+provides=("fontmatrix=${pkgver%%.r*}")
+conflicts=('fontmatrix')
+_srcdir="${pkgname%-*}"
+#source=('git+https://github.com/popolon/fontmatrix.git')
+source=('git+https://github.com/fontmatrix/fontmatrix.git')
sha256sums=('SKIP')
pkgver() {
- cd ${pkgname%-*}
- printf "$(git rev-list --count HEAD) $(git rev-parse --short HEAD)"|sed 's+ +.+g'
+ set -u
+ cd "${_srcdir}"
+ local _ver="$(git describe --long | sed -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g')"
+ _ver="${_ver#v}"
+ printf '%s' "${_ver}"
+ set +u
}
build() {
- cd ${pkgname%-*}
-
- [[ $CARCH == 'i686' ]] && _bits='32'
- [[ $CARCH == 'x86_64' ]] && _bits='64'
- export QTDIR=/usr
- export QMAKESPEC=/usr/share/qt/mkspecs/linux-g++-${_bits}
+ set -u
+ cd "${_srcdir}"
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
+ rm -rf 'build'
+ mkdir -p 'build'
+ cd 'build'
+ declare -A _bits=([i686]='32' [x86_64]='64')
+ QTDIR='/usr' \
+ QMAKESPEC="/usr/share/qt/mkspecs/linux-g++-${_bits[${CARCH}]}" \
cmake .. -DCMAKE_BUILD_TYPE='Release' -DCMAKE_INSTALL_PREFIX='/usr'
make
+ set +u
}
package() {
- cd ${pkgname%-*}/build
+ set -u
+ cd "${_srcdir}/build"
make DESTDIR="${pkgdir}" install
+ set +u
}
+set +u