summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-15 10:00:00 +1300
committercaltlgin2020-10-15 10:00:00 +1300
commitf011ee01a18c5f2dce15d980ebbf4bcdee05ebcd (patch)
tree126d0a3b09816574ba324aa8b042421cdc92e31d
parentc210d6031e63806f16b3f732ac3b85adcfacc0be (diff)
downloadaur-f011ee01a18c5f2dce15d980ebbf4bcdee05ebcd.tar.gz
Add to AUR
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD40
2 files changed, 20 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db3657b9d186..ebb91cb26544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = fontpreview
- pkgdesc = CLI tool to preview fonts
- pkgver = r19.a938103
+ pkgdesc = Highly customizable and minimal font previewer written in bash
+ pkgver = 1.0.6
pkgrel = 1
url = https://github.com/sdushantha/fontpreview
arch = any
license = MIT
- makedepends = git
- depends = xdotool
depends = fzf
depends = imagemagick
depends = sxiv
- source = git://github.com/sdushantha/fontpreview.git
- sha1sums = SKIP
+ depends = xdotool
+ source = fontpreview-1.0.6.tar.gz::https://github.com/sdushantha/fontpreview/archive/1.0.6.tar.gz
+ sha256sums = 5785ed96852b84e082c05af56d4811ea8a830ed714d683201a128436a32f7758
pkgname = fontpreview
diff --git a/PKGBUILD b/PKGBUILD
index 346a26a25128..d50d6ea7f177 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,21 @@
-# Maintainer: elsorino <elso at pm dot me>
-pkgname=fontpreview
-pkgver=r19.a938103
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='fontpreview'
+pkgver=1.0.6
pkgrel=1
-pkgdesc="CLI tool to preview fonts"
+pkgdesc='Highly customizable and minimal font previewer written in bash'
arch=('any')
-url="https://github.com/sdushantha/fontpreview"
+url='https://github.com/sdushantha/fontpreview'
license=('MIT')
-provides=($_pkgname)
-conflicts=($_pkgname)
-depends=(
- 'xdotool'
- 'fzf'
- 'imagemagick'
- 'sxiv'
- )
-makedepends=('git')
-source=("git://github.com/sdushantha/fontpreview.git")
-sha1sums=('SKIP')
+depends=('fzf' 'imagemagick' 'sxiv' 'xdotool')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('5785ed96852b84e082c05af56d4811ea8a830ed714d683201a128436a32f7758')
-pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dvm755 "${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-package() {
- cd $srcdir/$pkgname
- install -d $pkgdir/usr/bin
- install -m755 fontpreview $pkgdir/usr/bin
- install -D -m644 "LICENSE" "$pkgdir/usr/share/licenses/fontpreview/LICENSE.md"
-} \ No newline at end of file
+# vim: ts=2 sw=2 et: