summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrian2020-02-09 03:24:49 +0100
committercrian2020-02-09 03:24:49 +0100
commit796a2fd212b4272a4b587f998a2886229da1b9aa (patch)
tree3b9cf72076f92c30ee414cd0567a0951e8996ebc
downloadaur-796a2fd212b4272a4b587f998a2886229da1b9aa.tar.gz
Initital upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eeef1425c2bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fontpreview-git
+ pkgdesc = Very customizable and minimal font previewer written in bash
+ pkgver = r19.a938103
+ pkgrel = 1
+ url = https://github.com/sdushantha/fontpreview
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = xdotool
+ depends = fzf
+ depends = imagemagick
+ depends = sxiv
+ provides = fontpreview
+ conflicts = fontpreview
+ source = git://github.com/sdushantha/fontpreview.git
+ sha256sums = SKIP
+
+pkgname = fontpreview-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceb644edbc26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: crian <crian84 at gmail dot com>
+
+pkgname=fontpreview-git
+pkgver=r19.a938103
+pkgrel=1
+pkgdesc="Very customizable and minimal font previewer written in bash"
+arch=('any')
+url="https://github.com/sdushantha/fontpreview"
+license=('MIT')
+depends=('xdotool' 'fzf' 'imagemagick' 'sxiv')
+makedepends=('git')
+provides=('fontpreview')
+conflicts=('fontpreview')
+source=("git://github.com/sdushantha/fontpreview.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd fontpreview
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd fontpreview
+ install -m755 -D fontpreview "$pkgdir/usr/bin/fontpreview"
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}