summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2018-03-21 11:29:06 +0100
committerSanskritFritz2018-03-21 11:29:06 +0100
commitb24e360974010235a5f6135e68c8c6b6a9415c45 (patch)
tree66069ed25f96dd944c5df5fd04dd0d3232d1c954
parent7da61be882e82a3f7f040a6811a7413f2ce5ac1f (diff)
downloadaur-b24e360974010235a5f6135e68c8c6b6a9415c45.tar.gz
Fixed python2 issue.
Contributed by dv-romanov.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f14e1ee7b4f..3eff4b3d1a56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Mar 5 21:39:35 UTC 2018
+# Wed Mar 21 09:44:39 UTC 2018
pkgbase = fontypython
pkgdesc = Manage, view and find your fonts.
pkgver = 0.5
- pkgrel = 1
+ pkgrel = 2
url = https://savannah.nongnu.org/projects/fontypython
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index e6cb161c31bf..3aa6df272509 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fontypython
pkgver=0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Manage, view and find your fonts."
arch=('any')
url="https://savannah.nongnu.org/projects/fontypython"
@@ -11,6 +11,10 @@ depends=('wxpython')
source=("http://download.savannah.nongnu.org/releases/fontypython/fontypython-$pkgver.tar.gz")
sha256sums=('46f5304f9ec790b0b870f66a37b5fd47103a9300d0e0ed98e8799bd59bb4ec1b')
+prepare() {
+ sed -i 's|c1 = \[ "python", os.path.join(fontyroot,|c1 = [ "python2", os.path.join(fontyroot,|g' "fontypython-$pkgver/fontypythonmodules/segwrapfonty.py"
+}
+
build() {
cd ${srcdir}/${pkgname}-${pkgver}
python2 setup.py build