summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-08-25 18:55:51 +0200
committerAlexandre Bouvier2021-08-25 18:55:51 +0200
commit2948cf058f9432741510e214773bf81591c9a0b6 (patch)
tree5a0213ffb038d448a2bcc68fe20ed511792f3a2a
parentf6fc5d0a559c7df0d2b9015227c9980703acf75c (diff)
downloadaur-2948cf058f9432741510e214773bf81591c9a0b6.tar.gz
update to 3.0.4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0bd27f01739..9e4c602bcaea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = foobar2000-component-playcount-bin
pkgdesc = Collects playback statistics for your music
- pkgver = 3.0.2
+ pkgver = 3.0.4
pkgrel = 1
url = https://www.foobar2000.org/components/view/foo_playcount
arch = any
license = unknown
makedepends = wget
- depends = foobar2000>=1.1.0
- conflicts = foobar2000-playcount-bin
- replaces = foobar2000-playcount-bin
- source = foo_playcount.fb2k-component::https://www.foobar2000.org/components/view/foo_playcount
- md5sums = 1699e277414cedf2def7df6c3f3f2e54
+ optdepends = foobar2000>=1.4
+ provides = foobar2000-component-playcount
+ conflicts = foobar2000-component-playcount
+ source = Playback Statistics.fb2k-component::https://www.foobar2000.org/components/view/foo_playcount
+ b2sums = 805105e27ed13421ee51980898d9a276d2d0515ef647866e381f53bbd0cb580789acd33eeaed8b30200799d8dd53fc8f41758f8bb5e33362d1380a1462e53a71
pkgname = foobar2000-component-playcount-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 440faa93c066..6f31a7321b14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-#!/bin/bash
-# shellcheck disable=SC2034
-# Maintainer: Alexandre Bouvier <contact at amb dot tf>
-pkgname=foobar2000-component-playcount-bin
-pkgver=3.0.2
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+_pkgname=foobar2000-component-playcount
+pkgname=$_pkgname-bin
+pkgver=3.0.4
pkgrel=1
pkgdesc="Collects playback statistics for your music"
arch=('any')
url="https://www.foobar2000.org/components/view/foo_playcount"
license=('unknown')
-depends=('foobar2000>=1.1.0')
makedepends=('wget')
-conflicts=('foobar2000-playcount-bin')
-replaces=('foobar2000-playcount-bin')
-source=("foo_playcount.fb2k-component::https://www.foobar2000.org/components/view/foo_playcount")
-md5sums=('1699e277414cedf2def7df6c3f3f2e54')
+optdepends=('foobar2000>=1.4')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("Playback Statistics.fb2k-component::$url")
+b2sums=('805105e27ed13421ee51980898d9a276d2d0515ef647866e381f53bbd0cb580789acd33eeaed8b30200799d8dd53fc8f41758f8bb5e33362d1380a1462e53a71')
# bypass dynamic download link
DLAGENTS=('https::/usr/bin/wget -nd -rl1 -A fb2k-component')
package() {
# shellcheck disable=SC2154
- install -Dm644 -t "$pkgdir/usr/share/foobar2000/components" foo_playcount.dll
+ install -Dm644 -t "$pkgdir"/usr/share/foobar2000/components foo_playcount.dll
}