summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:22:19 +0000
committerAntonio Rojas2019-04-03 06:22:19 +0000
commitd2b7fde22dd8b3a79b516ff5404d22e97602e4d0 (patch)
tree2471dec0a8b084869562923dcd545ee1c45e20ee
downloadaur-d2b7fde22dd8b3a79b516ff5404d22e97602e4d0.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
-rw-r--r--foobillard-3.0a-as-needed.patch10
-rw-r--r--foobillard-3.0a-fbsd.patch29
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..deb6a715c223
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = foobillard++
+ pkgdesc = An OpenGL billiard game
+ pkgver = 3.42beta
+ pkgrel = 6
+ url = http://foobillardplus.sourceforge.net/
+ arch = x86_64
+ license = GPL2
+ depends = freetype2
+ depends = libpng
+ depends = glu
+ depends = sdl_net
+ depends = sdl_mixer
+ replaces = foobillard
+ source = http://downloads.sourceforge.net/foobillardplus/foobillardplus-3.42beta.tar.gz
+ sha1sums = 51507efab0f595cfff26149003faf669c0a42f32
+
+pkgname = foobillard++
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7b1818af715
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=foobillard++
+pkgver=3.42beta
+pkgrel=6
+pkgdesc="An OpenGL billiard game"
+arch=('x86_64')
+url="http://foobillardplus.sourceforge.net/"
+license=('GPL2')
+depends=('freetype2' 'libpng' 'glu' 'sdl_net' 'sdl_mixer')
+replaces=('foobillard')
+source=(http://downloads.sourceforge.net/foobillardplus/foobillardplus-${pkgver}.tar.gz)
+sha1sums=('51507efab0f595cfff26149003faf669c0a42f32')
+
+prepare() {
+ cd foobillardplus-${pkgver}
+ sed -i 's|/opt/foobillardplus/bin/||' foobillardplus.desktop
+ sed -i 's|/opt/foobillardplus/||' foobillardplus.desktop
+ sed -e 's|freetype-config|pkg-config freetype2|g' -i src/Makefile.am
+ sed -e 's|inline float|float|g' -i src/vmath.*
+}
+
+build() {
+ cd foobillardplus-${pkgver}
+ aclocal --force
+ autoconf -f
+ autoheader -f
+ automake -a -c -f
+ ./configure --prefix=/usr/share
+ make
+}
+
+package() {
+ cd foobillardplus-${pkgver}
+ make DESTDIR="${pkgdir}" datadir="${pkgdir}/usr/share/foobillardplus/data" \
+ prefix="$pkgdir"/usr/share install
+
+ install -d "${pkgdir}"/usr/{bin,share/{applications,pixmaps}}
+ mv "${pkgdir}"/usr/share/{AUTHORS,COPYING,ChangeLog,INSTALL,README,TODO} "${pkgdir}/usr/share/foobillardplus"
+ mv "${pkgdir}"/usr/share/foobillardplus.desktop "${pkgdir}"/usr/share/applications
+ mv "${pkgdir}"/usr/share/foobillardplus.{png,xbm} "${pkgdir}"/usr/share/pixmaps
+ ln -s /usr/share/foobillardplus/bin/foobillardplus "${pkgdir}"/usr/bin/foobillardplus
+}
diff --git a/foobillard-3.0a-as-needed.patch b/foobillard-3.0a-as-needed.patch
new file mode 100644
index 000000000000..272f9c711778
--- /dev/null
+++ b/foobillard-3.0a-as-needed.patch
@@ -0,0 +1,10 @@
+--- foobillard-3.0a.old/src/Makefile.am 2004-02-25 07:23:56.000000000 +0100
++++ foobillard-3.0a/src/Makefile.am 2008-12-06 21:57:03.000000000 +0100
+@@ -83,6 +83,5 @@ AM_CFLAGS = -Wall `freetype-config --cfl
+
+ #LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
+ #LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
+-AM_LDFLAGS = ${all_libraries} `pkg-config --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS}
+ #LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz -L/home/floh/nvsdk/OpenGL/lib/ -lnvparse
+-LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
++LIBS = ${all_libraries} `pkg-config --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS} ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
diff --git a/foobillard-3.0a-fbsd.patch b/foobillard-3.0a-fbsd.patch
new file mode 100644
index 000000000000..3b7fc953a4de
--- /dev/null
+++ b/foobillard-3.0a-fbsd.patch
@@ -0,0 +1,29 @@
+Index: foobillard-3.0a/configure.in
+===================================================================
+--- foobillard-3.0a.orig/configure.in
++++ foobillard-3.0a/configure.in
+@@ -13,7 +13,7 @@ dnl Checks for libraries.
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(limits.h unistd.h math.h stdlib.h stdio.h)
++AC_CHECK_HEADERS(limits.h unistd.h math.h stdlib.h stdio.h endian.h sys/endian.h)
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+Index: foobillard-3.0a/src/billard3d.c
+===================================================================
+--- foobillard-3.0a.orig/src/billard3d.c
++++ foobillard-3.0a/src/billard3d.c
+@@ -24,7 +24,11 @@
+ #include <string.h>
+ #include <math.h>
+ #include <unistd.h>
++#ifdef HAVE_ENDIAN_H
+ #include <endian.h>
++#elif defined(HAVE_SYS_ENDIAN_H)
++#include <sys/endian.h>
++#endif
+
+ #ifndef USE_SDL
+ #include <GL/glut.h>