summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-03-26 13:33:41 -0600
committeryochananmarqos2019-03-26 13:33:41 -0600
commit0e9593060a9524e2b75275b3d9a6e743e95ec37e (patch)
tree23162ff14b014e47387be96101f34eff280f5f05
downloadaur-0e9593060a9524e2b75275b3d9a6e743e95ec37e.tar.gz
initial upload
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD32
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41e4fd41b948
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = foobnix-git
+ pkgdesc = Music player for Linux
+ pkgver = 3.1.r113.8ce2d8c2
+ pkgrel = 1
+ url = http://www.foobnix.com
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python2-distutils-extra
+ depends = python2-chardet
+ depends = python2-cairo
+ depends = python2-simplejson
+ depends = python2-mutagen
+ depends = gst-plugins-good
+ depends = gst-plugins-base
+ depends = gst-python2
+ depends = webkitgtk
+ depends = libkeybinder3
+ depends = gettext
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = gst-libav
+ depends = fuseiso
+ depends = python2-notify
+ depends = lame
+ depends = faac
+ depends = python2-keybinder2
+ depends = ffmpeg
+ depends = python2-dbus
+ provides = foobnix
+ conflicts = foobnix
+ source = git+https://github.com/foobnix/foobnix
+ sha256sums = SKIP
+
+pkgname = foobnix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e11fb797f29b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=foobnix-git
+pkgver=3.1.r113.8ce2d8c2
+pkgrel=1
+pkgdesc="Music player for Linux"
+arch=('i686' 'x86_64')
+url="http://www.foobnix.com"
+license=('GPL3')
+depends=('python2-chardet' 'python2-cairo' 'python2-simplejson' 'python2-mutagen'
+ 'gst-plugins-good' 'gst-plugins-base' 'gst-python2' 'webkitgtk' 'libkeybinder3' 'gettext'
+ 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'fuseiso' 'python2-notify' 'lame' 'faac'
+ 'python2-keybinder2' 'ffmpeg' 'python2-dbus')
+makedepends=('python2-distutils-extra')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/foobnix/foobnix')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}