summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Carl2019-12-15 18:30:44 -0800
committerJens Carl2019-12-15 18:30:44 -0800
commitb9c7f09a1191f48dd024669805947d3fad0f8f59 (patch)
tree7021d552911e23abc04cf5688cca695426353ac1
downloadaur-b9c7f09a1191f48dd024669805947d3fad0f8f59.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4061d778692a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = foonathan_memory
+ pkgdesc = STL compatible C++ memory allocator library using a new RawAllocator concept that is similar to an Allocator but easier to use and write.
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = http://foonathan.net/memory
+ arch = x86_64
+ license = ZLIB
+ makedepends = cmake
+ makedepends = git
+ source = foonathan_memory-0.6.2.tar.gz::https://github.com/foonathan/memory/archive/v0.6-2.tar.gz
+ source = git+https://github.com/foonathan/compatibility.git#commit=cd14212
+ sha256sums = cf302578f3b6721707b8428fd9b97182ada1970ce56f8881ea0b3390b97e66e3
+ sha256sums = SKIP
+
+pkgname = foonathan_memory
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18c731fe2619
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jens Carl <jc [dot] archlinux [at] jens-carl [dot] de>
+
+pkgname=foonathan_memory
+pkgver=0.6.2
+_pkgver=0.6-2
+pkgrel=1
+pkgdesc="STL compatible C++ memory allocator library using a new RawAllocator concept that is similar to an Allocator but easier to use and write."
+url="http://foonathan.net/memory"
+arch=('x86_64')
+license=('ZLIB')
+makedepends=('cmake' 'git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/foonathan/memory/archive/v${_pkgver}.tar.gz"
+ 'git+https://github.com/foonathan/compatibility.git#commit=cd14212')
+sha256sums=('cf302578f3b6721707b8428fd9b97182ada1970ce56f8881ea0b3390b97e66e3' 'SKIP')
+
+prepare() {
+ cd "${srcdir}/memory-${_pkgver}/"
+ rm -rf build && mkdir build
+
+ cd cmake/comp
+ ln -sf "${srcdir}/compatibility/comp_base.cmake"
+}
+
+build() {
+ cd "${srcdir}/memory-${_pkgver}"
+
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/memory-${_pkgver}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd build
+ make DESTDIR="${pkgdir}/" install
+}