summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-09 07:45:57 +0100
committersL1pKn072020-03-09 07:45:57 +0100
commitcdf7d63cfbb6713feb6cc4672354d71b9538a194 (patch)
treee3a2c27aa5c0778b47ae4a0b3c637cd700d1304b
downloadaur-cdf7d63cfbb6713feb6cc4672354d71b9538a194.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD69
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97207794c80b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = foosynth-plugin-delogohd-git
+ pkgdesc = Plugin for Vapoursynth: delogohd (Dual interface for Vapoursynth/Avisynth) (GIT version)
+ pkgver = r10.0.g8f343b7
+ pkgrel = 1
+ url = https://github.com/HomeOfAviSynthPlusEvolution/DelogoHD
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = vapoursynth
+ makedepends = avisynthplus
+ depends = gcc-libs
+ source = delogohd::git+https://github.com/HomeOfAviSynthPlusEvolution/DelogoHD.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-delogohd-git
+ pkgdesc = Plugin for Avisynth: delogohd (GIT version)
+ depends = avisynthplus
+ provides = avisynth-plugin-delogohd
+ conflicts = avisynth-plugin-delogohd
+
+pkgname = vapoursynth-plugin-delogohd-git
+ pkgdesc = Plugin for Vapoursynth: delogohd (GIT version)
+ depends = vapoursynth
+ provides = vapoursynth-plugin-delogohd
+ conflicts = vapoursynth-plugin-delogohd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d9c887d0936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=delogohd
+pkgbase="foosynth-plugin-${_plug}-git"
+pkgname=("avisynth-plugin-${_plug}-git"
+ "vapoursynth-plugin-${_plug}-git"
+ )
+pkgver=r10.0.g8f343b7
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
+arch=('x86_64')
+url='https://github.com/HomeOfAviSynthPlusEvolution/DelogoHD'
+license=('GPL2')
+depends=('gcc-libs')
+makedepends=('git'
+ 'cmake'
+ 'vapoursynth'
+ 'avisynthplus'
+ )
+source=("${_plug}::git+https://github.com/HomeOfAviSynthPlusEvolution/DelogoHD.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+
+ # unbundled
+ rm -fr include/{VapourSynth,VSHelper,avisynth}.h
+ rm -fr include/avs
+
+ mkdir -p build
+
+}
+
+build() {
+ cd "${_plug}/build"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} $(pkg-config --cflags vapoursynth avisynth)"
+
+ make
+}
+
+package_avisynth-plugin-delogohd-git() {
+ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+ depends=('avisynthplus')
+ provides=("avisynth-plugin-${_plug}")
+ conflicts=("avisynth-plugin-${_plug}")
+
+ install -Dm644 "${_plug}/build/libDelogoHD.so" "${pkgdir}/usr/lib/avisynth/libDelogoHD.so"
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+}
+
+package_vapoursynth-plugin-delogohd-git() {
+ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+ depends=('vapoursynth')
+ provides=("vapoursynth-plugin-${_plug}")
+ conflicts=("vapoursynth-plugin-${_plug}")
+
+ install -Dm644 "${_plug}/build/libDelogoHD.so" "${pkgdir}/usr/lib/vapoursynth/libDelogoHD.so"
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+} \ No newline at end of file