summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-06 03:02:08 +0200
committersL1pKn072021-10-06 03:02:08 +0200
commitb4e056d91f827639292cfbb93d682c1a9b5033d0 (patch)
tree14415473074b760794957b151f0d92cc0e259dbe
downloadaur-b4e056d91f827639292cfbb93d682c1a9b5033d0.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD67
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3920a39594f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = foosynth-plugin-knlmeanscl-git
+ pkgdesc = Plugin for Vapoursynth: knlmeanscl (GIT version)
+ pkgver = 1.1.1.r571.c4af339
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=171379
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = opencl-headers
+ makedepends = meson
+ makedepends = boost
+ makedepends = vapoursynth
+ makedepends = avisynthplus
+ depends = opencl-icd-loader
+ provides = vapoursynth-plugin-knlmeanscl
+ conflicts = vapoursynth-plugin-knlmeanscl
+ source = knlmeanscl::git+https://github.com/pinterf/KNLMeansCL
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-knlmeanscl-git
+ pkgdesc = Plugin for Avisynth: knlmeanscl (GIT version)
+ depends = opencl-icd-loader
+ depends = avisynthplus
+ provides = avisynth-plugin-knlmeanscl
+ conflicts = avisynth-plugin-knlmeanscl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..089084a2f947
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=knlmeanscl
+pkgbase="foosynth-plugin-${_plug}-git"
+pkgname=(# "vapoursynth-plugin-${_plug}-git"
+ "avisynth-plugin-${_plug}-git")
+pkgver=1.1.1.r571.c4af339
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=171379'
+license=('GPL')
+depends=('opencl-icd-loader')
+makedepends=('git'
+ 'opencl-headers'
+ 'meson'
+ 'boost'
+ 'vapoursynth'
+ 'avisynthplus'
+ )
+conflicts=("vapoursynth-plugin-${_plug}")
+provides=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/pinterf/KNLMeansCL")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ _ver="$(cat KNLMeansCL/NLMDefault.h | grep -m1 '#define VERSION' | grep -o "[[:digit:]]*" | paste -sd'.')"
+ echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" \
+ --buildtype=release
+
+ ninja
+}
+
+package_avisynth-plugin-knlmeanscl-git() {
+ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+ depends+=('avisynthplus')
+ provides=("avisynth-plugin-${_plug}")
+ conflicts=("avisynth-plugin-${_plug}")
+
+ install -Dm644 build/libknlmeanscl.so "${pkgdir}/usr/lib/avisynth/libknlmeanscl.so"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_vapoursynth-plugin-knlmeanscl-git() {
+ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+ depends+=('vapoursynth')
+ provides=("vapoursynth-plugin-${_plug}")
+ conflicts=("vapoursynth-plugin-${_plug}")
+
+ install -Dm644 build/libknlmeanscl.so "${pkgdir}/usr/lib/vapoursynth/libknlmeanscl.so"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+