summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-09 17:29:17 +0100
committersL1pKn072022-02-09 17:37:05 +0100
commitd6e726b8a875d23eb612954d8fb04caa82c380ce (patch)
tree2d4c3355f8be7158f435c91ccdd196a76a94aa86
parent6499e859d3526ceb4b3dcf271dcfaf4fb2547b83 (diff)
downloadaur-d6e726b8a875d23eb612954d8fb04caa82c380ce.tar.gz
bump and split package. seems this plugion have 2 maintainers, one for VS and other fer Avs in different repo. so...
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD61
2 files changed, 24 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fcaf6088142..cd5f47b07945 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = foosynth-plugin-lsmashsource-git
- pkgdesc = Plugin for Avisynth/Vapoursynth: lsmashsource (GIT version)
- pkgver = r1092.83c0251
+ pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
+ pkgver = vA.3h.1.g4a7a981
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=167435
arch = x86_64
@@ -11,22 +11,6 @@ pkgbase = foosynth-plugin-lsmashsource-git
makedepends = vapoursynth
makedepends = l-smash
makedepends = ffmpeg
- source = lsmashsource::git+https://github.com/AmusementClub/L-SMASH-Works.git#branch=vs-api4
- sha256sums = SKIP
-
-pkgname = avisynth-plugin-lsmashsource-git
- pkgdesc = Plugin for Avisynth: lsmashsource (GIT version)
- depends = avisynthplus
- depends = libavutil.so
- depends = libavformat.so
- depends = libavcodec.so
- depends = libswscale.so
- depends = liblsmash.so
- provides = avisynth-plugin-lsmashsource
- conflicts = avisynth-plugin-lsmashsource
-
-pkgname = vapoursynth-plugin-lsmashsource-git
- pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
depends = vapoursynth
depends = libavutil.so
depends = libavformat.so
@@ -35,3 +19,7 @@ pkgname = vapoursynth-plugin-lsmashsource-git
depends = liblsmash.so
provides = vapoursynth-plugin-lsmashsource
conflicts = vapoursynth-plugin-lsmashsource
+ source = lsmashsource::git+https://github.com/AmusementClub/L-SMASH-Works.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-lsmashsource-git
diff --git a/PKGBUILD b/PKGBUILD
index efa7ada66c68..f87be198f096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,20 @@
_plug=lsmashsource
pkgbase="foosynth-plugin-${_plug}-git"
-pkgname=("avisynth-plugin-${_plug}-git"
- "vapoursynth-plugin-${_plug}-git"
- )
-pkgver=r1092.83c0251
+pkgname=("vapoursynth-plugin-${_plug}-git")
+pkgver=vA.3h.1.g4a7a981
pkgrel=1
-pkgdesc="Plugin for Avisynth/Vapoursynth: ${_plug} (GIT version)"
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://forum.doom9.org/showthread.php?t=167435'
license=('LGPL')
+depends=('vapoursynth'
+ 'libavutil.so'
+ 'libavformat.so'
+ 'libavcodec.so'
+ 'libswscale.so'
+ 'liblsmash.so'
+ )
makedepends=('git'
'meson'
'avisynthplus'
@@ -18,62 +23,32 @@ makedepends=('git'
'l-smash'
'ffmpeg'
)
-source=("${_plug}::git+https://github.com/AmusementClub/L-SMASH-Works.git#branch=vs-api4")
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/AmusementClub/L-SMASH-Works.git")
sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
- #echo "$(git describe --long --tags | tr - .)"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "$(git describe --long --tags | tr - .)"
}
prepare() {
- mkdir -p build-{avisynth,vapoursynth}
+ mkdir -p build
rm -fr "${_plug}/include"
}
build() {
- (cd build-vapoursynth
+ cd build
arch-meson "../${_plug}/VapourSynth" \
--buildtype=release
- ninja
- )
- (cd build-avisynth
- arch-meson "../${_plug}/AviSynth" \
- --buildtype=release
- ninja
- )
-}
-package_avisynth-plugin-lsmashsource-git() {
- pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
- depends=('avisynthplus'
- 'libavutil.so'
- 'libavformat.so'
- 'libavcodec.so'
- 'libswscale.so'
- 'liblsmash.so'
- )
- provides=("avisynth-plugin-${_plug}")
- conflicts=("avisynth-plugin-${_plug}")
+ ninja
- DESTDIR="${pkgdir}" ninja -C build-avisynth install
- install -Dm644 "${_plug}/VapourSynth/README" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README"
}
package_vapoursynth-plugin-lsmashsource-git() {
- pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
- depends=('vapoursynth'
- 'libavutil.so'
- 'libavformat.so'
- 'libavcodec.so'
- 'libswscale.so'
- 'liblsmash.so'
- )
- provides=("vapoursynth-plugin-${_plug}")
- conflicts=("vapoursynth-plugin-${_plug}")
-
- DESTDIR="${pkgdir}" ninja -C build-vapoursynth install
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${_plug}/AviSynth/README" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}