summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-01-08 06:27:12 +0100
committersL1pKn072021-01-08 06:27:12 +0100
commitebbe7fa67eeceb458da1656ec99f95f287149747 (patch)
tree384ff871e9d5ebd72ae1fe29a280127b8959aa99
downloadaur-ebbe7fa67eeceb458da1656ec99f95f287149747.tar.gz
Initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD77
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2345be7b7007
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = foosynth-plugin-lsmashsource-git
+ pkgdesc = Plugin for Avisynth/Vapoursynth: lsmashsource (GIT version)
+ pkgver = r1057.5873965
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=167435
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = meson
+ makedepends = avisynthplus
+ makedepends = vapoursynth
+ makedepends = l-smash
+ makedepends = ffmpeg
+ source = lsmashsource::git+https://github.com/HolyWu/L-SMASH-Works.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-lsmashsource-git
+ pkgdesc = Plugin for Avisynth: lsmashsource (GIT version)
+ depends = avisynthplus
+ depends = libavutil.so
+ depends = libavformat.so
+ depends = libavcodec.so
+ depends = libswscale.so
+ depends = liblsmash.so
+ provides = avisynth-plugin-lsmashsource
+ conflicts = avisynth-plugin-lsmashsource
+
+pkgname = vapoursynth-plugin-lsmashsource-git
+ pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
+ depends = vapoursynth
+ depends = libavutil.so
+ depends = libavformat.so
+ depends = libavcodec.so
+ depends = libswscale.so
+ depends = liblsmash.so
+ provides = vapoursynth-plugin-lsmashsource
+ conflicts = vapoursynth-plugin-lsmashsource
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..572594574bd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=lsmashsource
+pkgbase="foosynth-plugin-${_plug}-git"
+pkgname=("avisynth-plugin-${_plug}-git"
+ "vapoursynth-plugin-${_plug}-git"
+ )
+pkgver=r1057.5873965
+pkgrel=1
+pkgdesc="Plugin for Avisynth/Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=167435'
+license=('LGPL')
+makedepends=('git'
+ 'meson'
+ 'avisynthplus'
+ 'vapoursynth'
+ 'l-smash'
+ 'ffmpeg'
+ )
+source=("${_plug}::git+https://github.com/HolyWu/L-SMASH-Works.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build-{avisynth,vapoursynth}
+
+ rm -fr "${_plug}/include"
+}
+
+build() {
+ (cd build-vapoursynth
+ arch-meson "../${_plug}/VapourSynth"
+ ninja
+ )
+ (cd build-avisynth
+ arch-meson "../${_plug}/AviSynth"
+ ninja
+ )
+}
+
+package_avisynth-plugin-lsmashsource-git() {
+ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+ depends=('avisynthplus'
+ 'libavutil.so'
+ 'libavformat.so'
+ 'libavcodec.so'
+ 'libswscale.so'
+ 'liblsmash.so'
+ )
+ provides=("avisynth-plugin-${_plug}")
+ conflicts=("avisynth-plugin-${_plug}")
+
+ DESTDIR="${pkgdir}" ninja -C build-avisynth install
+ install -Dm644 "${_plug}/VapourSynth/README" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README"
+}
+
+package_vapoursynth-plugin-lsmashsource-git() {
+ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+ depends=('vapoursynth'
+ 'libavutil.so'
+ 'libavformat.so'
+ 'libavcodec.so'
+ 'libswscale.so'
+ 'liblsmash.so'
+ )
+ provides=("vapoursynth-plugin-${_plug}")
+ conflicts=("vapoursynth-plugin-${_plug}")
+
+ DESTDIR="${pkgdir}" ninja -C build-vapoursynth install
+ install -Dm644 "${_plug}/AviSynth/README" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+}