summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-17 17:44:12 +0100
committersL1pKn072022-02-17 17:44:12 +0100
commitf2c984707b14961ddf85441a989708ddbd91f4a9 (patch)
treea6694505f5530c8388722a753ff6220c76ec230f
parentd6e726b8a875d23eb612954d8fb04caa82c380ce (diff)
downloadaur-f2c984707b14961ddf85441a989708ddbd91f4a9.tar.gz
provisional ffmpeg4.4 build
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5f47b07945..461c12f0e998 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = foosynth-plugin-lsmashsource-git
pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
pkgver = vA.3h.1.g4a7a981
- pkgrel = 1
+ pkgrel = 2
url = https://forum.doom9.org/showthread.php?t=167435
arch = x86_64
license = LGPL
makedepends = git
makedepends = meson
- makedepends = avisynthplus
makedepends = vapoursynth
makedepends = l-smash
- makedepends = ffmpeg
+ makedepends = ffmpeg4.4
depends = vapoursynth
- depends = libavutil.so
- depends = libavformat.so
- depends = libavcodec.so
- depends = libswscale.so
depends = liblsmash.so
+ depends = libavcodec.so=58-64
+ depends = libavformat.so=58-64
+ depends = libavutil.so=56-64
+ depends = libswresample.so=3-64
+ depends = libswscale.so=5-64
provides = vapoursynth-plugin-lsmashsource
conflicts = vapoursynth-plugin-lsmashsource
+ options = debug
source = lsmashsource::git+https://github.com/AmusementClub/L-SMASH-Works.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f87be198f096..e686c06470df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,30 @@ _plug=lsmashsource
pkgbase="foosynth-plugin-${_plug}-git"
pkgname=("vapoursynth-plugin-${_plug}-git")
pkgver=vA.3h.1.g4a7a981
-pkgrel=1
+pkgrel=2
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://forum.doom9.org/showthread.php?t=167435'
license=('LGPL')
depends=('vapoursynth'
- 'libavutil.so'
- 'libavformat.so'
- 'libavcodec.so'
- 'libswscale.so'
'liblsmash.so'
+ 'libavcodec.so=58-64'
+ 'libavformat.so=58-64'
+ 'libavutil.so=56-64'
+ 'libswresample.so=3-64'
+ 'libswscale.so=5-64'
)
makedepends=('git'
'meson'
- 'avisynthplus'
'vapoursynth'
'l-smash'
- 'ffmpeg'
+ 'ffmpeg4.4'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/AmusementClub/L-SMASH-Works.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
@@ -41,6 +42,8 @@ prepare() {
build() {
cd build
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+
arch-meson "../${_plug}/VapourSynth" \
--buildtype=release