summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-04-18 10:45:42 +0200
committersL1pKn072020-04-18 10:45:42 +0200
commit164b8b95320cf026e7d9f699cebbb8638d8d0d34 (patch)
treee3ad12d282b0b88c4182de4f4304fd7e42012fc1
downloadaur-164b8b95320cf026e7d9f699cebbb8638d8d0d34.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD71
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d6467a71b0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = foosynth-plugin-neo_f3kdb-git
+ pkgdesc = Plugin for Vapoursynth/Avisynth: neo_f3kdb (Dual interface for Vapoursynth/Avisynth) (GIT version)
+ pkgver = r4.1.gc9ec0f8
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=176553
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = avisynthplus-git
+ makedepends = vapoursynth
+ source = neo_f3kdb::git+https://github.com/HomeOfAviSynthPlusEvolution/neo_f3kdb.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-neo_f3kdb-git
+ pkgdesc = Plugin for Avisynth: neo_f3kdb (GIT version)
+ depends = avisynthplus
+ depends = intel-tbb
+ provides = avisynth-plugin-neo_f3kdb
+ conflicts = avisynth-plugin-neo_f3kdb
+
+pkgname = vapoursynth-plugin-neo_f3kdb-git
+ pkgdesc = Plugin for Vapoursynth: neo_f3kdb (GIT version)
+ depends = vapoursynth
+ depends = intel-tbb
+ provides = vapoursynth-plugin-neo_f3kdb
+ conflicts = vapoursynth-plugin-neo_f3kdb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..300a542d8569
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!esee.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68e895fb8a73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=neo_f3kdb
+pkgbase="foosynth-plugin-${_plug}-git"
+pkgname=("avisynth-plugin-${_plug}-git"
+ "vapoursynth-plugin-${_plug}-git"
+ )
+pkgver=r4.1.gc9ec0f8
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth/Avisynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=176553'
+license=('GPL3')
+makedepends=('git'
+ 'cmake'
+ 'avisynthplus-git'
+ 'vapoursynth'
+ )
+source=("${_plug}::git+https://github.com/HomeOfAviSynthPlusEvolution/neo_f3kdb.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --first-parent --tags --always | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+
+ mkdir -p build
+
+ sed '1i#include <cpuid.h>' -i src/cpuid.cpp
+}
+
+build() {
+ cd "${_plug}/build"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package_avisynth-plugin-neo_f3kdb-git() {
+ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+ depends=('avisynthplus'
+ 'intel-tbb'
+ )
+ provides=("avisynth-plugin-${_plug}")
+ conflicts=("avisynth-plugin-${_plug}")
+
+ install -Dm644 "${_plug}/build/libneo-f3kdb.so" "${pkgdir}/usr/lib/avisynth/libneo-f3kdb.so"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_vapoursynth-plugin-neo_f3kdb-git() {
+ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+ depends=('vapoursynth'
+ 'intel-tbb'
+ )
+ provides=("vapoursynth-plugin-${_plug}")
+ conflicts=("vapoursynth-plugin-${_plug}")
+
+ install -Dm644 "${_plug}/build/libneo-f3kdb.so" "${pkgdir}/usr/lib/vapoursynth/libneo-f3kdb.so"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+