summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-08-28 22:39:54 +0200
committersL1pKn072021-08-28 22:39:54 +0200
commitc4a046a61ca56eca5e65ed5ebebe63a2bf864174 (patch)
tree54c7df2854dc56dc5b272367cffd156304ba4853
parent3dcc94ce4d2f4617eec3d0a56a2c60db79c09c5d (diff)
downloadaur-c4a046a61ca56eca5e65ed5ebebe63a2bf864174.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8bdd9784630..4131e6118b66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = foosynth-plugin-neo_f3kdb-git
pkgdesc = Plugin for Vapoursynth/Avisynth: neo_f3kdb (Dual interface for Vapoursynth/Avisynth) (GIT version)
- pkgver = r6.6.g94cb6a4
+ pkgver = r7.0.ga72cf3d
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=176553
arch = x86_64
@@ -9,20 +9,18 @@ pkgbase = foosynth-plugin-neo_f3kdb-git
makedepends = cmake
makedepends = avisynthplus
makedepends = vapoursynth
+ makedepends = tbb
source = neo_f3kdb::git+https://github.com/HomeOfAviSynthPlusEvolution/neo_f3kdb.git
sha256sums = SKIP
pkgname = avisynth-plugin-neo_f3kdb-git
pkgdesc = Plugin for Avisynth: neo_f3kdb (GIT version)
depends = avisynthplus
- depends = intel-tbb
provides = avisynth-plugin-neo_f3kdb
conflicts = avisynth-plugin-neo_f3kdb
pkgname = vapoursynth-plugin-neo_f3kdb-git
pkgdesc = Plugin for Vapoursynth: neo_f3kdb (GIT version)
depends = vapoursynth
- depends = intel-tbb
provides = vapoursynth-plugin-neo_f3kdb
conflicts = vapoursynth-plugin-neo_f3kdb
-
diff --git a/PKGBUILD b/PKGBUILD
index 823349cc44ea..04a78df2af6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase="foosynth-plugin-${_plug}-git"
pkgname=("avisynth-plugin-${_plug}-git"
"vapoursynth-plugin-${_plug}-git"
)
-pkgver=r6.6.g94cb6a4
+pkgver=r7.0.ga72cf3d
pkgrel=1
pkgdesc="Plugin for Vapoursynth/Avisynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
arch=('x86_64')
@@ -15,6 +15,7 @@ makedepends=('git'
'cmake'
'avisynthplus'
'vapoursynth'
+ 'tbb'
)
source=("${_plug}::git+https://github.com/HomeOfAviSynthPlusEvolution/neo_f3kdb.git")
sha256sums=('SKIP')
@@ -32,17 +33,17 @@ prepare() {
build() {
cd "${_plug}/build"
cmake .. \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_COMPILER=clang++ \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} $(pkg-config --cflags vapoursynth) $(pkg-config --cflags avisynth)"
make
}
package_avisynth-plugin-neo_f3kdb-git() {
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
- depends=('avisynthplus'
- 'intel-tbb'
- )
+ depends=('avisynthplus')
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
@@ -54,9 +55,7 @@ package_avisynth-plugin-neo_f3kdb-git() {
package_vapoursynth-plugin-neo_f3kdb-git() {
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
- depends=('vapoursynth'
- 'intel-tbb'
- )
+ depends=('vapoursynth')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")