summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-09 02:23:46 +0200
committersL1pKn072021-10-09 02:23:46 +0200
commite0512a20593dd68ebaa3fe0fc507a71b45d28b9e (patch)
tree5481a907f57293390cbe7b89c37d7abe3b1a79a5
parent400b996a902c15d9e09b9c6f9507c6d97e22bd05 (diff)
downloadaur-e0512a20593dd68ebaa3fe0fc507a71b45d28b9e.tar.gz
bump
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05a0dba36856..7ee286306d45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = foosynth-plugin-neo_fft3dfilter-git
pkgdesc = Plugin for Vapoursynth/Avisynth: neo_fft3dfilter (Dual interface for Vapoursynth/Avisynth) (GIT version)
- pkgver = r10.1.g1537395
+ pkgver = r11.0.g5def131
pkgrel = 1
- url = https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D.git
+ url = https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = git
makedepends = cmake
makedepends = fftw
- makedepends = intel-tbb
+ makedepends = tbb
makedepends = avisynthplus
makedepends = vapoursynth
source = neo_fft3dfilter::git+https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D.git
@@ -18,7 +18,7 @@ pkgname = avisynth-plugin-neo_fft3dfilter-git
pkgdesc = Plugin for Avisynth: neo_fft3dfilter (GIT version)
depends = avisynthplus
depends = fftw
- depends = intel-tbb
+ depends = tbb
provides = avisynth-plugin-neo_fft3dfilter
conflicts = avisynth-plugin-neo_fft3dfilter
@@ -26,7 +26,6 @@ pkgname = vapoursynth-plugin-neo_fft3dfilter-git
pkgdesc = Plugin for Vapoursynth: neo_fft3dfilter (GIT version)
depends = vapoursynth
depends = fftw
- depends = intel-tbb
+ depends = tbb
provides = vapoursynth-plugin-neo_fft3dfilter
conflicts = vapoursynth-plugin-neo_fft3dfilter
-
diff --git a/PKGBUILD b/PKGBUILD
index c6baa9218286..ad49f97cca9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@ pkgbase="foosynth-plugin-${_plug}-git"
pkgname=("avisynth-plugin-${_plug}-git"
"vapoursynth-plugin-${_plug}-git"
)
-pkgver=r10.1.g1537395
+pkgver=r11.0.g5def131
pkgrel=1
pkgdesc="Plugin for Vapoursynth/Avisynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
arch=('x86_64')
-url='https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D.git'
-license=('GPL')
+url='https://github.com/HomeOfAviSynthPlusEvolution/neo_FFT3D'
+license=('GPL2')
makedepends=('git'
'cmake'
'fftw'
- 'intel-tbb'
+ 'tbb'
'avisynthplus'
'vapoursynth'
)
@@ -34,7 +34,7 @@ prepare() {
build() {
cd "${_plug}/build"
cmake .. \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make
@@ -44,12 +44,12 @@ package_avisynth-plugin-neo_fft3dfilter-git() {
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
depends=('avisynthplus'
'fftw'
- 'intel-tbb'
+ 'tbb'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
- install -Dm644 "${_plug}/build/libneo-fft3d.so" "${pkgdir}/usr/lib/avisynth/libneo-fft3d.so"
+ install -Dm755 "${_plug}/build/libneo-fft3d.so" "${pkgdir}/usr/lib/avisynth/libneo-fft3d.so"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
@@ -59,12 +59,12 @@ package_vapoursynth-plugin-neo_fft3dfilter-git() {
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
depends=('vapoursynth'
'fftw'
- 'intel-tbb'
+ 'tbb'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
- install -Dm644 "${_plug}/build/libneo-fft3d.so" "${pkgdir}/usr/lib/vapoursynth/libneo-fft3d.so"
+ install -Dm755 "${_plug}/build/libneo-fft3d.so" "${pkgdir}/usr/lib/vapoursynth/libneo-fft3d.so"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"