summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Eklöf2020-05-25 21:17:32 +0200
committerDaniel Eklöf2020-05-25 21:17:32 +0200
commit1a7e21d67d588a88ee319b435fcdaa2ac441c157 (patch)
tree50be25babd62ddf31725ac3482244bb8c9141fc6
parentf1cf692ab7de012be0cee6e0a2d0b87ba165b9c1 (diff)
downloadaur-1a7e21d67d588a88ee319b435fcdaa2ac441c157.tar.gz
Set "-O3 -fno-plt" explicitly
Adding -O3 works around a GCC 10.1 O2+PGO performance regression.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 989901a67ac9..b664313e509a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = foot-git
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://codeberg.org/dnkl/foot
arch = x86_64
license = mit
diff --git a/PKGBUILD b/PKGBUILD
index 470e6eac74de..b8f67131e2a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Eklöf <daniel at ekloef dot se>
pkgname=('foot-git' 'foot-terminfo-git')
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url=https://codeberg.org/dnkl/foot
license=(mit)
@@ -29,7 +29,12 @@ build() {
ln -sf ../../fcft .
popd
- meson --prefix=/usr --buildtype=release --wrap-mode=forcefallback -Db_lto=true -Dc_args="-Wno-missing-profile" . build
+ # makepkg uses -O2 by default, but we *really* want -O3
+ # -Wno-missing-profile since we're not exercising everything when doing PGO builds
+ # -fno-plt because performance (this is the default in makepkg anyway)
+ export CFLAGS+=" -O3 -Wno-missing-profile -fno-plt"
+
+ meson --prefix=/usr --buildtype=release --wrap-mode=forcefallback -Db_lto=true . build
if [[ -v WAYLAND_DISPLAY ]]; then
meson configure -Db_pgo=generate build