summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Eklöf2021-04-22 21:56:44 +0200
committerDaniel Eklöf2021-04-22 21:56:44 +0200
commit74068d17b86ea6cdd8aa06a24cd74382d5f5d129 (patch)
tree6ebaf68b9e5910a398165f545759901a30d4ba53
parent3853b7c5d20f4a73a693e6a539bffa4d7e39d176 (diff)
downloadaur-74068d17b86ea6cdd8aa06a24cd74382d5f5d129.tar.gz
Don’t fail build if the tests in the PGO generate phase fails
This patch makes two changes related to the test run done in the PGO generate phase: * Don’t fail the build if any of the tests are failing (|| true) * Add -k0 to the “ninja test” command line; this ensures we continue and execute the remaining tests if one test fails.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1417dab66e76..844d18d6873d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = foot-git
pkgver = 1.7.2
- pkgrel = 2
+ pkgrel = 3
url = https://codeberg.org/dnkl/foot
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index b58309b794b6..73a25b204418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Eklöf <daniel at ekloef dot se>
pkgname=('foot-git' 'foot-terminfo-git')
pkgver=1.7.2
-pkgrel=2
+pkgrel=3
arch=('x86_64' 'aarch64')
url=https://codeberg.org/dnkl/foot
license=(mit)
@@ -55,7 +55,7 @@ build() {
# Need to run tests here, to ensure *all* generated binaries have
# profiling data (including e.g. unit tests from fcft/tllist).
- ninja -C build test
+ ninja -k 0 -C build test || true
local script_options="--scroll --scroll-region --colors-regular --colors-bright --colors-256 --colors-rgb --attr-bold --attr-italic --attr-underline --sixel"