summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2024-03-14 21:57:36 +0100
committerbegin-theadventure2024-03-14 21:57:36 +0100
commit06c45d30d581d10d1d4ebdecf5e6c5ac8a307f51 (patch)
tree9dcbacbe5fa8e8fea81901e361183b44a4f2badf
parent095a0ee03e9bf0118ae2e53c90365241f3d4593f (diff)
downloadaur-06c45d30d581d10d1d4ebdecf5e6c5ac8a307f51.tar.gz
1.3.2, SPDX license, & update depends!
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD13
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 463e7476d253..9af807892bba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = footage
pkgdesc = Polish your videos
- pkgver = 1.3.1
- pkgrel = 2
+ pkgver = 1.3.2
+ pkgrel = 1
url = https://gitlab.com/adhami3310/Footage
arch = x86_64
arch = aarch64
- license = GPL3
+ license = GPL-3.0-only
checkdepends = appstream-glib
makedepends = blueprint-compiler
makedepends = cargo
@@ -13,16 +13,21 @@ pkgbase = footage
makedepends = meson
depends = a52dec
depends = fdkaac
+ depends = ffmpeg
depends = gst-editing-services
- depends = gst-plugins-rs
+ depends = gst-plugin-gif
+ depends = gst-plugin-gtk4
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
depends = gstreamer-svt-av1
+ depends = gstreamer-vaapi
depends = libadwaita
depends = libmpeg2
depends = svt-av1
depends = vo-aacenc
depends = x264
depends = x265
- source = git+https://gitlab.com/adhami3310/Footage.git#tag=v1.3.1
+ source = git+https://gitlab.com/adhami3310/Footage.git#tag=v1.3.2
sha256sums = SKIP
pkgname = footage
diff --git a/PKGBUILD b/PKGBUILD
index 736e1d052eff..c0bd6d47c442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
pkgname=footage
-pkgver=1.3.1
-pkgrel=2
+pkgver=1.3.2
+pkgrel=1
pkgdesc="Polish your videos"
url="https://gitlab.com/adhami3310/Footage"
+license=('GPL-3.0-only')
arch=('x86_64' 'aarch64')
-license=('GPL3')
-depends=('a52dec' 'fdkaac' 'gst-editing-services' 'gst-plugins-rs' 'gstreamer-svt-av1'
+depends=('a52dec' 'fdkaac' 'ffmpeg' 'gst-editing-services' 'gst-plugin-gif' 'gst-plugin-gtk4'
+ 'gst-plugins-bad' 'gst-plugins-ugly' 'gstreamer-svt-av1' 'gstreamer-vaapi'
'libadwaita' 'libmpeg2' 'svt-av1' 'vo-aacenc' 'x264' 'x265')
makedepends=('blueprint-compiler' 'cargo' 'git' 'meson')
checkdepends=('appstream-glib')
@@ -17,13 +18,13 @@ sha256sums=('SKIP')
prepare() {
cd Footage
export CARGO_HOME="$srcdir/CARGO_HOME"
- export RUSTUP_TOOLCHAIN=stable
+ export RUSTUP_TOOLCHAIN=nightly
cargo fetch --target "$CARCH-unknown-linux-gnu"
}
build() {
export CARGO_HOME="$srcdir/CARGO_HOME"
- export RUSTUP_TOOLCHAIN=stable
+ export RUSTUP_TOOLCHAIN=nightly
arch-meson Footage build
meson compile -C build
}