summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-06-20 00:45:20 +0200
committerbegin-theadventure2023-06-20 00:45:20 +0200
commitfd6ca59172ad0b9dc866aadc91c4673c191faa63 (patch)
tree979446f9fa6fae17e3fad3419912dfab78a45cbd
downloadaur-fd6ca59172ad0b9dc866aadc91c4673c191faa63.tar.gz
1.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..816e021d656e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = footage
+ pkgdesc = Trim, flip, rotate and crop individual clips. Footage is a useful tool for quickly editing short videos and screencasts. It's also capable of exporting any video into a format of your choice
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://gitlab.com/adhami3310/Footage
+ arch = any
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = blueprint-compiler
+ makedepends = cargo
+ makedepends = git
+ makedepends = meson
+ depends = gst-editing-services
+ depends = libadwaita
+ source = git+https://gitlab.com/adhami3310/Footage.git#tag=v1.1
+ sha256sums = SKIP
+
+pkgname = footage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58258350cffb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=footage
+pkgdesc="Trim, flip, rotate and crop individual clips. Footage is a useful tool for quickly editing short videos and screencasts. It's also capable of exporting any video into a format of your choice"
+pkgver=1.1
+pkgrel=1
+arch=('any')
+url="https://gitlab.com/adhami3310/Footage"
+license=('GPL3')
+depends=('gst-editing-services' 'libadwaita')
+makedepends=('blueprint-compiler' 'cargo' 'git' 'meson')
+checkdepends=('appstream-glib')
+source=("git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson Footage build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlog
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm644 Footage/README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+ install -Dm644 Footage/COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
+}