summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Seletskiy2015-07-15 14:45:46 +0600
committerStanislav Seletskiy2015-07-15 14:45:46 +0600
commitc071e190893ee848d73e42ee93f2afa60ec5f4de (patch)
tree9d971b57af8c2391b275fb39c1836771a3886153
downloadaur-c071e190893ee848d73e42ee93f2afa60ec5f4de.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4850a3b3e26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = footswitch-git
+ pkgdesc = Command-line utility for PCsensor foot switch
+ pkgver = 11.f2bfaa2
+ pkgrel = 1
+ url = https://github.com/rgerganov/footswitch
+ arch = any
+ license = GPL
+ source = git+https://github.com/rgerganov/footswitch
+ md5sums = SKIP
+
+pkgname = footswitch-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..92761630bb96
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/footswitch/
+/*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32e5e7773f02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname="footswitch-git"
+pkgver=11.f2bfaa2
+pkgrel=1
+pkgdesc="Command-line utility for PCsensor foot switch"
+url="https://github.com/rgerganov/footswitch"
+arch=('any')
+license=('GPL')
+makedepends=()
+source=(git+https://github.com/rgerganov/footswitch)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "footswitch"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd "footswitch"
+
+ make
+}
+
+package() {
+ install -D "$srcdir/footswitch/footswitch" "$pkgdir/usr/bin/footswitch"
+}